Cannot get USB storage to work on Intel NUC 8

(Kim Kruse Petersen) #1

No matter what I try in the BIOS on the NUC 8, I cannot make the USB connected disk visible. I have enabled all USB ports.

Anyone with a hint on NUC 8. generation?

#2

Visible where, in Roon over Network? What type of USB disk?

(Kim Kruse Petersen) #3

Different USB memory sticks, 5 different. Must the file format always be extFAT, and is this the “normal” fileformat on USB sticks?

(Mike) #4

We recommend USB drives connected to ROCK be formatted exFAT if you requires compatibility, or EXT4 if you don’t.

ROCK will also work with NTFS ,FAT32, and EXT2/3/4 drives, but if you are starting fresh with USB storage, our recommendation would be to use exFAT.

https://kb.roonlabs.com/ROCK:_Storage_Basics

(Kim Kruse Petersen) #5

Fine, I have tried that but nothing shows up in the storage folder or on storage in Roon configuration. I have checked Intel support page to see if a setting in BIOS is wrong, but with no succes.
Strange.

#6

If this is the variant where you connect to the share form a PC, you can only see the content of connected drives. You can plug the drive in your PC and add a file to the drive there, then plug the drive back in to your ROCK and check the share again.

(Kim Kruse Petersen) #8

It still does not show anything in Storage to pick from.

I am happy I have a NAS server working perfectly.

(Kim Kruse Petersen) #9

@support: I still never got the Roon ROCK to list any kind of disks connected to the Intel NUC 8. generation running Roon via the USB connections. I have tried all USB`s.

USB storage is not listed in Roon or in Win Explorer under “storage”.

Do you have any reporting on specific Intel NUC 8. generation issue regarding this?

(Noris) #10

Hi @Kim_Kruse_Petersen,

Can you share a few screenshots of what you see in the Storage folder for both the Roon interface and also for what you see when you smb into the ROCK (via Explorer or OSX finder)?

I assume you have also tried one of the other USB ports on the ROCK and that has the same behavior? Are you able to use those USB ports with a DAC or something else?

I have not seen any other reports for this issue, have you followed the ROCK setup guide to the letter including updating the BIOS? Have you configured the BIOS properly?

#12

I have not been able to get usb sticks to show up in ROCK either but have no issues with USB disks.

(Kim Kruse Petersen) #13

Not much to report in screen shots. Only my normal shares are shown on the ROCK storage. Nothing to see in the Storage folder from Explorer.

Setup as described in the ROCK setup guide.

But: I have updated to firmware 0056 as guide instructs to update to latest BIOS. But now the latest BIOS for the Intel NUC 8i5BEH is 0051. It seems that Intel have withdrawn the 0056 version.

Could it be an issue on the NUC / BIOS combination for 8. generation?
I have also tried with USB disks and not USB sticks. Still no succcess.

This is really strange!

(Noris) #14

Hi @Kim_Kruse_Petersen,

Thanks for letting me know that info. I am going to reach out to our hardware team to see if they can take a look at this issue.

Also, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

– Noris

(Noris) #15

Hi @Kim_Kruse_Petersen,

I spoke to the technical team regarding this issue. Can I please ask you to reproduce this behavior once more and note the exact local time in your country (e.g 7:47PM) that you notice the drive not appear? After letting me know this info, please do not reboot your ROCK until I confirm that the diagnostics package has reached our servers.

– Noris

(Kim Kruse Petersen) #16

Hi @noris! There is no specific time for the issue, as I never is able to see any USB storage attached to the NUC, generation 8.

So what to do?

(Noris) #17

Hi @Kim_Kruse_Petersen,

Can you try this:

  • Have no USB storage connected to the NUC
  • Try plugging in a USB attached storage
  • Note the exact local time that you plugged it in and it does not appear (e.g. 12:56PM)
  • Let me know the exact model/manufacturer of the USB drive, the file format it’s using and timestamp
  • Do not reboot your NUC until I confirm that diagnostics are in

– Noris