Cannot get watched folders setup on Win 11 device

Roon Core Machine

NUC7I5BNK – with 8GB RAM running ROCK with music files attached via USB.

Networking Gear & Setup Details

  • Core is attached via Ethernet cable to home network running on Netgear Router.
  • Win 11 – Desktop that runs Roon Server and RAATServer. Not sure why I installed RAATServer.

Connected Audio Devices

Presently, only attached device is Cambridge CXN on ethernet network, which is attached to speakers.

Number of Tracks in Library

So far only music files is USB attached device, running 27231 tracks, 7k albums. I would like to use this device for backup but I cannot get watched folders to connect.

Description of Issue

I am writing to get help configuring my Roon Core to watch a folder on my desktop computer. I have a database on C:\My Music, but I cannot add this or any other folder as a watched folder.

I have tried the following:
• Opening Roon Settings and navigating to the Storage tab.
• Clicking the “Add Folder” button.
• Selecting the “Browse” option and navigating to
\BACK-OFFICE\C:\My Music.
• Clicking the “OK” button.

However, the folder does not appear in the list of watched folders. I do not have a USER NAME OR PASSWORD set on the share.

I have tried various iterations including substituting the IP address, removing the desktop name, copying and pasting from windows explorer and countless times manually adding the folder by entering the path, but this also fails.

I have tried restarting Roon, but this does not resolve the issue. I also reinstalled ROCK and the Roon Server on this new machine. What am I not doing correctly?
I am running Roon Core on a Windows 11 desktop computer. I have the latest version of Roon installed. (See image below)

I would appreciate any assistance you can provide me with resolving this issue.

Thanks in advance,

You need to first share the folder on Windows

Thanks Mario, Yes I did share both the folder and I also went so far as to share the C:\ drive. Also, made certain that those with access was everyone.

Make sure you are running as a private network and have file and printer sharing turned on.

(Look under control panel, network and sharing, advanced sharing options.)

Also, not sure if it matters, but you don’t need to run roon server on the windows machine if you are running rock as your core/server.

1 Like

Well, you may have done that, but you still need to enter valid Windows Credentials in Roon’s Add network share screen - you can’t leave those fields blank.

1 Like

Hmm, even if the Share’d drive credentials has access to ‘Everyone’?

Dunno.

Microsoft doesn’t like anyone without valid Windows Credentials accessing shared folders…

It’s “Everyone” - i.e. the list of known Windows Credentials holders, not “Anyone”…

2 Likes

Geof – Thanks for sharing your knowledge. In the add network share screen the user, password & workgroup are optional. I do not use them on my network, so what other credentials are you referencing? Where do I find them?

This is somewhat hard to believe as Microsoft actively works hard on deprecating SMB v1 since years.

Notes:

  • Windows defaults to use your login credentials when connecting to a remote share and only ask for credentials if the default doesn’t work – so if the default works, it might look like you don’t need proper credentials but it’s not true.

  • From the replies of Roon staff on other threads I suspect that Roon OS may have dropped SMB v1 support a few versions back. If this is true, you need to setup an SMB v2 compliant share on your Windows machine (implies no access without username/password) and set a password for your Windows account if you use it without one currently (or enable the guest account and allow guest account sharing, or create a local user account with password just for Roon to access the share).

If you share a Windows folder over the network, then during the setting up of the share you must associate Windows Credentials with the folder - and these must in turn be used in the Roon Add network share screen. See this article for refeberence: