Cannot heart album, just keeps trying forever

Happens after clicking the +, just get the loading animation where the heart should be. This is on MPB M1 latest macOS. Without the heart I can’t add a new tag.

Anyone else getting this or know a fix? Cheers.

Edit: I tried another album and it worked, this happened yesterday too, weird!


Same happened to me but I found that although the scrolling continued, the album was added to my library. I ignored it and just moved onto another page.

Have you tried to restart the server? I get this and similar behavior when the memory has clogged up. Restarting the roon server usually solves it.

1 Like

Thanks for the advice. I was on trial but cancelled before my subscription started, too many bugs/quarks and it was frustrating. I’ll give it another go in a few months. Cheers.

Yes I’m getting it too on my iPad by not on iPhone or MBP… Darn gremlins…

I get better results from Add to Library in the three dots button.

1 Like

This has been bad since last iOS update for me.

Thank you Fireapple! That works much better for me too.

1 Like

Have this behavior since long time. In my setup the same appears, if the album was already added to the library.

If it happens to you, just cross check in versions, and you will see, if it already exists. In my case: it does!