Cannot join Tidal to Roon

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


I tried to config “Services”, join Tidal to Roon. It redirect to webpage, I login there it and got:
“You’ve successfully connected your TIDAL account.” but in services Tidal stays “not configured”.
I have also verified my Tidal account thru Tidal app. I have tried this via MacOS and IOS. Always same result. i have only Apple devices to choose right now. Any tricks to try?

I have Roon Rock: Version 1.0 (build 219) stable and software Version 1.7 (build 571) stable


Under Settings>Services, select Edit for Tidal and log out.
Then shut down your Rock core via the Rock GUI, and turn it back on again.
Then go back to Settings>Services and sign in to Tidal again.

I cannot logout since I’am not loged in. Tried to shutdown roon core (power off/power on) and then login again but it behaves the same.

I should have thought of that… :anguished:

I find the solution for the problem. It was all about DNS setting issue.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.