Cannot login to Roon

Getting stuck at the login screen. Tried uninstalling and reinstalling Roon but no luck.
Please help!

Hi Scott,

The Support devs will see this thread on their usual rounds. It will assist them if you could set out some details of the computer and OS you are using and what happens at the login screen.


I am using Mac OS X Version 10.11.6 and Roon Version 1.2 (build 157).
When I try and login to Roon, The logging in and icon just stay on the screen and nothing happens (see image below). Please let me know if there are other details you need.

Thank you,

Thanks Scott,

Are you wanting to start the free trial or are you logging in to an existing account and licence ?

I already have a license and am trying to log into my account

Thanks Scott,

Let’s flag @kevin and @eric to see if they can work out whether this is account related or an issue with the login software. I hope they can work it out so you can get in as soon as possible.

Thanks Andrew,
However, I’m not sure that it’s a problem with my account since I can login on the website.
What did the Logs file say?

Did you have a dirty shutdown by any chance? I had this recently after tripping one of the phases in my house’s distribution board…Roon had been doing a lot of rescanning as a result of changes I’d made to my files and the dirty shutdown resulted in database corruption.

Yes. My computer crashed last week due to a faulty RAM module and I had to erase my hard drive and reinstall the OS and all my apps.

I also tried uninstalling and reinstalling Roon but it didn’t solve the problem.

I hate to say this, but stop Roon, make a copy of your database, reinstate a backup if you have one or delete the existing database and restart Roon. If that solves the problem the copy you just made is corrupt and can be deleted.

1 Like

Thank you.