Cannot login to Tidal or Qobuz Following Power Outage

Core Machine (Operating system/System info/Roon build number)

Core is on a NUC8i7BEH with 8GB (2x4GB) Corsair DDR4 SO-DIMM Vengeance Performance RAM and a 250GB Samsung 970 EVO Plus M.2 running ROCK. A separate locally installed Corsair SSD drive hosts my local Music which is 283 Albums (3308 Tracks) ripped to FLAC. I mainly listen to streamed music from Tidal and Qobuz. Roon OS 1.0 Build 186,

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Network is BT Halo FTTC Internet > DrayTec Vigor 130 Modem > Asus RT-5300 Tri-Band Gigabit WiFi Router > NETGEAR ProSAFE GS108 Gigabit Switch > Roon ROCK NUC > Cambridge Audio Azur 951N Streamer (originally via RoPieee on Ethernet, but now direct as the 851N had Roon support). Both NUC and streamer connected direct to Netgear switch.

The RT-5300 provides DHCP but I run my own DNS using PiHole which in turn uses Quad 9 ( as the Upstream DNS servers and uses DNSSEC.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

The 851N is the main Roon endpoint in use. Others are Windows PCs connected via Ethernet, a Laptop via WiFi, iPad via WiFi; and Roon Remote Controllers are Windows PCs/Laptop, iPad and Android Phone.

We had an area wide power outage, which of course just cut power to everything in the house.

Following reconnection of power, everything is working OK except Roon. Roon will play OK from my Local Library, but cannot connect to Tidal or Qobuz, nor it seems Roon backend as it cannot retrieve my Account information.

Roon will not connect to Tidal or Qobuz but will play from my Local Library

Both Tidal and Qobuz play OK from any PC, phone or iPad using their own client

Both Tidal and Qobuz will play direct on the 851N having entered logon credentials on the front panel and/or via the Cambridge Audio Stream Magic app. The 851N has WiFi disabled, all streams are via Ethernet.

In Services settings, Tidal is constantly attempting to logon with a never ending wheel:

Clicking Edit and entering credentials tells me I have successfully logged on to Tidal:

Clicking Edit and entering credentials tells me I have successfully logged on to Tidal:

But on return to Roon it is still attempting to log on as above…

Attempting to logon to Qobuz fails with a Network error:

Attempting to access my Roon Account fails:

Roon About fails to be able to check for an update:

Everything else on my internal network works perfectly, the issue seems to be ROCK communicating with Roon Labs back end.

Things I have tried:

Playing Tidal & Qobuz direct from their own Client apps on several devices, including the 851N – All OK

Cleared the Roon Cache

Restarting Roon Server using the ROCK Webb GUI

Shutting Down Roon Server using the ROCK Webb GUI and powering on again

Re-Installing Roon Server using the ROCK Webb GUI

I disconnected the DrayTec Modem and Asus Router and plugged in the BT Home Hub standard router to replace them, but all the same issues existed, so the problem is not my core Internet interface of modem and router, ROCK cannot get to Roon Labs for some reason

I have now returned to my normal LAN setup and continue to troubleshoot but thought I would reach out in case I have Wood for Trees vision!

OK I have resolved the issue…

ROCK could not get back to Roon Labs back-end for some reasion, and I kept thinking either there is a problem at Roon labs or it is a DNS issue… But if there was a problem back at base, during the hours I have been trying to sort this out, it would have affected everyone, or a big sub-set of users and the Support topic would have been alive with problem posts - and it wasn’t, so it had to be DNS… But everything else on my internal network was resolving perfectly well.

Plus, when I shut down the DrayTec Modem and the Asus Router, I also bypassed the PiHole DNS server because it is directly connected to the disconnected and powered down Asus router, and I was therefore using standard ISP DNS config (because the BT Home Hub does not allow configuring alternative DNS servers), and yet the problem persisted.

So I am back on my normal LAN setup, and looking at the Roon ROCK management web page, and I realise that the IP address for my DNS server is hard coded, so when I tested with the standard BT router, the DNS server was not available, and there is no option to enter a secondary DNS server here, so it could not resolve… so I changed it to the IP address to, my Default Gateway (Asus Router) and BINGO, all was instantly well!!!

So then I entered the IP address of my preferred Upstream DNS (Quad Nine) and all is now well with the Roon world.

I have no idea why Roon Server no longer likes my PiHole DNS server, even though everything else goes via it with no problem, and why it stopped working coincided with the Power cut, when it has been working perfectly well via PiHole ever since I first set up ROCK last Summer, I have no idea. During my earlier trouble shooting, I did disable Filtering on the PiHole in case that were an issue, but it did not help.

So I have NO IDEA why ROCK Roon Server no longer works with PiHole DNS, but am happy to direct it straight to Quad Nine instead as there is no advertising to block anyway.

I don’t think anyone thought it was anything but your own convolutions. So no mad rush of volunteering to help :wink:

Well thank you for your kind words, but I have what is for a great many, a perfectly standard home network, nothing “convoluted” about it.

I’ve no idea why your ROCK Roon Server no longer works with your PiHole DNS either. My ROCK is still happily using my PiHole DNS - but then again, I haven’t had a power cut recently…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.