Cannot login to Tidal[Solved]

Hallo, My Roon is working perfectely however my contact with Tidals fails. I started with à free membership and everything goes well. Now I am paying for Tidal and when I go directly to Tidal everything is ok. However login in with Roon for Tidal using of course the same username and password login fails with the Text "there is an unexpected error, check your account.
So what to do? I miss logics!

Try this: in Roon go settings accounts and re-enter your Tidal account name and password.

As Carl suggests, and I concur, sometimes TIDAL loses the login connection, and Carl’s recommendation is akin to logging in again to “refreshen” the login. A few weeks ago, I had to intuit the same solution which worked immediately. Hope your outcome is as positive as mine.
Time and TIDAL wait…

Tanks Carl and Richard,

I am still puzzled:

  1. Roon is working perfectly

  2. Tidal stand alone is working perfectly ( so account name and password are ok). I paid and have a green V -sign.
    The only thing is that Roon does not connect with Tidal.

I followed your suggestion: settings - accounts and re-enter Roon. (Tidal is mentioned under the Services). After the new login I tried again to login with Tidal. Unfortunately it does not work.

Everything should be very simple but I cannot find the solution. Can you?

Please hearing from you,

Thom Pronk
Netherlands (Europe)

Hi Thom,

Try quitting Roon (or Roon Server) core and then restart.

Not sure if it’ll help in this situation, but it can’t hurt to try.

Cheers, Greg

Dear Thom,

The login for TIDAL through roon is the same as the login for TIDAL Have you contacted their support to inquire if your login information corresponds? Unless something between roon and TIDAL has been compromised, if your login information is correct, then perhaps TIDAL can help along with roon to sort out what the impediment is causing the failure to login. It may require both roon and TIDAL to enlist their help if you are entering the proper login User Name and Password.

I wish you well. Please let us know what you discover when successfully logging in when that resumes.


hello Richard,

Rebooting the Roonserver on the Synology NAS did the trick. Login with Tidal is no longer the problem. Happy!

Thanks for your ideas and quick responds.

Dear Thom,

Well done! Love happy endings. OR in your case, happy beginnings…
Enjoy the music,