Cannot play multichannel AAC file

Core Machine (Operating system/System info/Roon build number)

Roon Core 1.7 (710) is running on a Synology DS916+ without other issues

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core and all clients are connected via Ethernet (1Gbit lines)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

smsl m500 vial usb to an iMac running Roon client 1.7 (710)
Denon AV Receiver connected via HDMI to Roon Rock running on NUC10I3
The issue is not related to the endpoints

Description Of Issue
I have some ac3 raw files I captured as transport stream from digital radio. This format is used by German broadcasters when they broadcasts multichannel recordings from classical concerts via SAT Radio. I used ffmpeg to extract the ac3 files from the .ts file

This resulted in ac3 files with the following attributes
Input #0, ac3, from ‘bruckner_4.ac3’:
Duration: 00:22:28.03, start: 0.000000, bitrate: 448 kb/s
Stream #0:0: Audio: ac3, 48000 Hz, 5.0(side), fltp, 448 kb/s 24bit

please note the this is a 5.0 and not a 5.1 multichannel file. This is rare and I only see this from the German broadcasters ‘Bayerischer Rundfunk’ (BR) and ‘Norddeutscher Rundfunk’ (NDR) in their concert recordings.

According to your multichannel information Roon is supporting AAC for multichannel audio files but not AC3. Due to the fact that this is already a lossy format it makes no sense to create huge FLAC files an therefore I converted the ac3 file to AAC resulting in

Output #0, ipod, to ‘bruckner_4a.m4a’:
Metadata:
encoder : Lavf57.83.100
Stream #0:0: Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, 5.0(side), fltp, 325 kb/s
Metadata:
encoder : Lavc57.107.100 aac
size= 53800kB time=00:22:28.03 bitrate= 326.9kbits/s speed=21.9x
video:0kB audio:53552kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.463152%

This file is shown in macOS finder as
Bruckner_1_m4a Apple MPEG-4-Audio 48,9MB sampling rate 48khz channels 5 and plays perfectly outside Roon directly on the Mac.

When I add this m4a file to Roon the file is recognized but Roon reports only 2 channels:
Source: local
Format 326kbps AAC
sampling rate 48kHz
channels 2ch

and does not play the file but skips to the next after a couple of seconds

I need your help to convert the ac3 5.0 multichannel files in a way that Roon is accepting the files. FLAC is no option because this results in huge files.

kind regards
Chris

Hi @Chris_KA,

You can use ffmpeg to do the down-mixing for you:

ffmpeg -i "<input_file>" -ac 2 "<output_file>"

Where the -ac value specifies the number of audio channels desired in the target, 2 in this case. This post has more details and even ways that you can adjust the mix levels: https://superuser.com/questions/852400/properly-downmix-5-1-to-stereo-using-ffmpeg

While the examples are 5.1 the principles hold.

Good luck.

Thanks Carl,

I might be misunderstood here. I want to play theses 5.0 multichannel files via hdmi on my surround system and therefore need Roon to deal correctly with 5.0 encoded AAC files.

regards
Chris

Ahhh, I can be a little hard of understanding at times :wink: That’s a different problem and I’m not sure my help will do what it says on the tin, i.e. help. I hope you get this sorted.

Best,
Carl

Hi @Chris_KA,

Can you please upload a few examples of such files to Dropbox / Google Drive / etc. and send me a link via private message (click my name -> message)?

done. Thanks for jumping in

Hi @Chris_KA,

Thanks again for sending the files over, we have been able to reproduce the issue on our end.
We still need to investigate this further, but reproducing the issue is the critical first step, thanks for letting us know about this issue!

Hi Noris,

you are very welcome!

regards
Chris

1 Like

Hi @noris
I am returning to this topic to ask if there is already a solution in sight because surround files are piling up on my disk and I need to know how to proceed to evade doing metadata work multiple times.

Just for reference: I have a bunch of .ac3 files I got by recording multi-channel broadcasts of classical music from BR-KLASSIK, a german radio station. To add metadata and get these recordings seen and played by roon I need to convert them either to FLAC or AAC according to the Roon knowledge base article addressing multichannel files.
When I use FLAC the files get bloated to 8 times their original size without adding any quality due to the fact that the ac3 stream was obviously encoded in a lossy way (nevertheless the surround experience is exceptionally good). So from a info to data ratio AAC encoding with the same bitrate of 448k makes more sense. And here roon has the problem that it doesn’t recognize 5.0 or 5.1 encoded AAC files currently.

I would appreciate if you have a short update regarding this issue to help me planning my next steps

kind regards
Christoph

Hello @Chris_KA ,

I took a look at our internal tracker today, and I can see that your ticket is still in our development queue.

This means our developers are still planning to look at this, but we don’t yet have a timeframe for when that’s going to happen.

Once the ticket has been scheduled and work begins, I’ll have a better sense of timing here. For now, you may want to convert these to multichannel FLAC. Thanks in advance for your patience!

Hi @noris
this problem is still there and after more than a year I think you should either correct your documentation which states that multichannel AAC is supported or fix the problem. The actual state where the doc states that this is possible but after showing that this is not working no fix is provided is confusing and a bit upsetting.
Please decide if you want to drop the claim that multichannel AAC is supported of fix this ASAP

thanks and regards
Chris

Since you have issues with multichannel AAC; one approach could be to convert them to multichannel FLAC. These files works fine on my setup at least.

Yes, the problem occures also in the LMS.
I’ve used then GitHub - steve-tregidgo/spdifconvert: Utility to convert AC3/DTS files into WAVs suitable for streaming with a SqueezeBox
and create a flac with the result.
Nowadays BR Klassik is using AAC and so I see no other option to use flac, which is working without any problems and for me the need of space (hey, I’ve thousands of DSD tracks) isn’t a real show stopper.

Hi Tor,

yes I know that FLAC works but this isn’t my point.

  1. Roon states that multichannel AAC is supported so I think either they should provide this or change the help files.
  2. as I wrote in my first post above I do have audio only AC3 files from German Broadcasting recordings which are already lossy. It makes no sense to create huge FLAC files for this.

The obviously best solution would be if Roon would allow a passthrough option for formats like DTS AC3 and Atmos solely for passing multichannel music via hdmi to an AV Receiver.
Nevermind. I just want to do what should be possible according to the roon help files
Link: https://help.roonlabs.com/portal/en/kb/articles/multichannel
And it is not OK for Roon to know that AAC multichannnel dosen’t work for over a year now and still have this help file stating the opposite.

I know, the multichannel AAC should be fixed (could you need update of codec?), but to be able to play them now converting to FLAC could be one way to go.

I totally do not get what you want to say here.
I already acknowledged in my very fist post which startet this topic that FLAC multichannel is working but resulting in 5 times bigger files and that a codec problem might me part of this.
Do you want to relativize my problem to get clarification here - after one year?

Hi Burkhardt,
BR Klassik and NDR Kultur streaming AC3 over Satelite is exactly my use case. I have quite a collection. I use native ffmpeg to create the (unfortunately huge) flac files directly without the need to first convert to wav as a temporary solution.
I really hope the roon engineers live up to the documentation and make AAC 5.0 (BR Klassik) and AAC 5.1 (NDR Kultur) work.