Cannot play music on Core that has Realtek HD Audio [Solved - Exclusive Mode]

During the 14 trial days, roon works without major problem. But since i pay the Annual Membership Roon stop working!!! Perhaps there is not link between that two points but it’s strange.

Roon start, i can select an album, the correponding playlist appear but impossible to play music. All the title of the playlist appear shortly in the bottom control bar. Blue spot run left to right quikly on the progress bar during few seconds before doing the same thing with the next title in the playlist. I don’t understand what’s the problem.

Thanks in advance for your help,

Hi @Claude_Jonniaux — Apologies for the trouble here!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior occur for playback to all endpoints? If you play to the internal speakers of one of your remotes does the same thing occur?

Does this occur with all content or just specific types (TIDAL vs local, certain file types, etc.)?


I m back home, so i made test on two other output (Yamaha RX-V581 and WX-030) connected thru Airplay … and it work. The problem appear only for “System output” or Wasapi but for all the sources (Tidal, local).
If i unistall the RealTek HD Audio, “system output” is impossible to activate and wasapi is not proposed. Strange because that solution work partialy for me two weeks ago!!!

Roon last version 64bits.

PC is an Asus ROG Strix GL703GM under Win10 family,
(ram 16Gb, 256Gb ssd, 1 Tb hd, I7 last generation, …) BUT Realtek HD Audio

Network: Wifi maximum 5 or 6 hardware connected (1 printer, 1 Yamaha homeCinema, 1 ou 2 Smartphone, 2 pc). Internet connexion: download 90Mb/s upload 14Mb/s ping 12ms
Clearly no network problem :wink:

Test with music from Tidal and local store on hd and usb (less then 100 tracks).

Tidal’s account: Premium in Belgium.

Roon is the only one with problem. All the other software work perfectly with RealTek HD Audio (Tidal, Deezer, GrooveMusic, Firefox, Edge, IE, … and many more).

Tell me, if you need more specific informations, screenshot or video.

Sorry for my poor english is not my first language.

Hi @Claude_Jonniaux,

Since this only appears to be an issue with System Output, can you try uninstalling and reinstalling the RealTek drivers and let me know if there is any change here?

Since noticing this have you tried rebooting your Core machine?


As I wrote in a previous post, I uninstalled the RealTek HD Audio driver, but the “system output” was impossible to activate and the wasapi was not offered. Strange because this solution works partially for me two weeks ago !!!
14 days ago, the first time I installed Roon, I had a problem with the RealTek driver. So, I uninstalled RealTek and Roon. Without restarting the computer, I reinstalled Roon. Then I restarted the pc. The system has reinstalled the RealTek driver without notice … but everything works (system output and wasapi) for 2 weeks. Then I deactivated my account to test Roon on another PC. And after the test, when I reactivated my account on the first machine, the “system output” was impossible to activate and wasapi was not proposed :frowning:
I have tried to uninstall and reinstall only the Realtek driver or both (RealTek and Roon). I tried this, with and without rebooting between different steps … nothing works.
The kernel is on the same machine then the “client” part, so everything is restarted each time I start the pc.
While waiting for news, I continue to test different “solutions” … if miraculously one of them works, I will inform you :wink:

Hi @Claude_Jonniaux,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more (try enabling System Output) and note the time at which you try to do this. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hello @Claude_Jonniaux,

I wanted to follow up here with you to see if you had a chance to follow Dylan’s instructions and let us know the timestamps before we go ahead and enable diagnostics mode. please let me know if you still require assistance with this issue.


I have no time for the moment. I will try à last time to re-install roon when i will have more free time at the end of the month.

1 Like

Hi Dylan,

I found the solution. I set on the two parameters of the “Exclusive mode” in speaker parameter (see image). Setting exclusive mode in de wasapi output in the Roon parameter wasn’t sufficient.

We will probably never known why the “bug” appear suddenly … it’s Windows :wink:

Thanks for the following,


1 Like

Thanks for letting us know the cause @Claude_Jonniaux! This info will be helpful for anyone experiencing the same issue you are. Thanks again for contacting support!

– Noris

The follow-up by Roon’s support is far better than many other software company.

Thank you,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.