Cannot play music using Bose USB speakers

June 13, 2018 6:12 AM (Europe: Paris), June 12, 2018 9:12 PM (America: Los Angeles)

I cannot get any playback from Roon to my Bose 7 usb audio speakers.

They play youtube videos and audio files through windows groove perfectly well, but for some reason, Roon loads up the album, and then refuses to play. roon does play properly to my Oppo Sonica speaker via wi-fi
I am on Windows 10 Pro 64bit and have just installed Roon version 1.5 build 323
Any ideas?

With my Klipsch USB they show up as a zone in Roon.
Have you checked “settings\audio” in Roon to see if the Bose are enabled?

Looking through the forum turns up a number of reports of problems using Bose speakers with Roon. I don’t see that anyone has come up with a definitive solution, but perhaps the suggestion in this post might work for Bose speakers…

1 Like

Yes, that show up as a zone in Roon, but nothing happens when I try to play a file. Roon loads the tracks to play, but then doesn’t play.
The speakers will play direct from Tidal and Apple iTunes, just not from Roon

Hi @Bill_Thornton ----- Thank you for the report, the insight and feedback are both appreciated!

Moving forward, I agree with @Geoff_Coupe’s suggestion above (thanks Geoff :+1: ) and would kindly like to ask you to please enable the setting mentioned here (i.e “Work around devices that misreport capabilities”) on the Bose 7 audio zone in Roon and verify if this action yields a change in behavior.


Thanks everyone for the suggestions.
I implemented the workaround suggested by Eric Stewart, but no luck I’m afraid, exactly the same behavior.
The tracks load up to the queue, but then the play button gets greyed out and nothing plays.
I’m surprised that, if it is a known issue, why Roon Labs haven’t fixed it.
I know Bose aren’t the best speakers out there, but they are somewhat of a household name.
My main listening environment is streaming to Linn equipment, so this issue only concerns audio at my computer whilst I’m working. Ce’st la Vie, as they say.
Once again, thank you all for your help on this

Silly question but did you set the bose as the default speakers on the computer that they are hooked up to and then try to play to “system output” zone on that computer in roon?

Hello BearFNF,
Not a silly question at all, but yes, the Bose speakers are set as system default.
They appear as a zone inside Roon, but will not play in either their own zone or in the system output zone. I am pretty computer savvy, but I don’t honestly know if this is a usb, speaker or Roon problem.
All I know is that the speakers work fine with other media, ie youtube, iTunes and Groove music player.

Hey Bill,

Support just asked me about this and I took a look back through our records to refresh my memory about these devices.

To be clear, this doesn’t have anything to do with the speakers not being “the best” or anything like that – we absolutely want these to work, and we’ve made changes at least 3 times in the past attempting to resolve these issues, sadly to no avail.

From what we can tell, these speakers (or at least the Bose models we’ve looked at in the past) only accept 6 channel audio, which is a definitively non-standard way to design a product like this. The last time we took a long look at this problem we did not support multichannel, so there may be more we can do now to get this working.

We are going to open a ticket on this and have our developers look into it. @eric may be along to request some more information. It’s possible that supporting the design of these speakers means we have to make other compromises, but that’s a call for our developers to make once this ticket (and the associated technical details) are in front of them.

We’ll do what we can to get this working for you, and we appreciate your patience, Bill.

@Bill_Thornton — Thank you for giving the proposed test a shot and sharing the observations made during the requested troubleshooting exercise. The continued insight is very appreciated!

Just to “piggy back” on Mike’s previous a bit, I would like to gather some timestamps and diagnostics from you to pass over to our techs but before we gather that information I would like to kindly ask you to please perform one more test for me.

Being as you mentioned that the Bose speakers are set as the system default I would like you to navigate to the audio tab and do the following:

  • Disable the “Bose” audio zone.
  • Enable the “system output” zone.
  • Go to the “device setup” window for the “system output” zone and turn off “exclusive mode”.
  • Please confirm what the experience is like after the above adjustments are made.

Many thanks!

Hi Eric,
I tried your suggestions above, but no luck.
One thing though, there is no “Exclusive Mode” available in the “system output” zone.

This is a screen shot of my Roon settings

And this is a screen shot of my System output settings, hopefully these get through to you.
And no, the Bose speakers are not normally disabled, I just did that to follow your instructions.
Let me know what technical reports you need, and I will run them for you,

Hi @Bill_Thornton ---- Thank you for touching base with me, very appreciated! I must apologies as I see I “stumbled” over my words a bit when providing the procedure mentioned above :dizzy_face:. Again, my apologies.

Continuing forward, may I kindly ask you to perform the following in the order listed below:

Revised troubleshooting exercise:

  • Leave the “Bose” audio zone enabled.
  • Disable the “system output” zone.
  • Go to the “device setup” window for the “Bose” zone and turn off “exclusive mode”.
  • Please confirm what the experience is like after the above adjustments are made.

If the above does not yield any changes in behavior please restore the original settings being used with the Bose zone and proceed with the below…

Timestamps + Diagnostics:
I would like to enable diagnostics on your account so our techs can have a closer look into this behavior. However, before I enable this feature please reproduce the issue and note…

  1. The time of day when the issue occurred.
  2. What track and/or album you attempted to play at the time of the error.


Hello Eric,
I tried your suggestion again, but no change. been there and done that previously anyway.
This latest test was at 3:49 pm (PST) and I was trying to lay Rolling in the Deep from 21 by Adele.
I think the track choice is insignificant, as it doesn’t matter what I try to play.
Hope this gives you the information you need, please let me know what further diagnostics you want,
Bill Thornton

Hi @Bill_Thornton ---- Thank you for the follow up and my apologies for the wait here.

Now that I have the requested time frames (thank you again) I have enabled the mentioned diagnostics on your account. What this action will do is the next time that Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will keep an eye out for the upload and will touch base again once it has come in so you know we have it.


Hi @Bill_Thornton ---- I wanted to reach out because I checked our servers this morning and looks like the mentioned diagnostics did not come in yet :thinking: I just ran a quick test on my end and was able to grab diagnostics from the test core I have setup here so the system is working as expected.

I have re-enabled this feature on your account and will continue to monitor our servers to see if they come in as expected. However, I also would like to make sure your logs make it over to our techs in a timely manor. So as a fallback may I kindly ask you to please send us over a set of your “Roon” logs from the device hosting your Core, using the instructions found here.


Hello Eric,
Here is the link to the Roon logs from today, June 19th.

I had to uninstall and re-install Roon server and core because of issues with my Tidal account, which is probably the reason your diagnostics failed
Hope this works for you

Hi @Bill_Thornton ---- Thank you for getting in touch with me! A few things moving forward…

I tried to access the logs but I was having issues with the provided link, so in light of this I checked our servers and the diagnostics arrived. I checked the logs attached to the report and can see there is only a single log file available. This is almost certainly caused by the reinstall and unfortunately the time frames listed above are no longer available for review.

In light of this, may I kindly ask you to please perform the requested procedure once more and when I have the new time frames I will re-enable diagnostics.