Cannot play through OPPO BDP-105D

I can play all my music though all devices except the OPPO. The windows driver is working because I can still play the music using JRiver. So, hardware-wise everything should be good. I’ve tried all the different device setup options in ROON but still will play. This should be easy. Anyone have this problem? OPPO connected to core using USB.

There is an ASIO driver provided by OPPO. Have you tried it?

Yes, I’m currently using driver version 3.26 for windows 10, which I recently re-installed. I’m getting a good connection when I use JRiver. But I want to stop using that program and use Roon exclusively. Could it be that JRiver has taken full control of the OPPO?

Are you shutting down JRiver completely before trying Roon?

Yes, I shut down JRiver and reboot the computer so it isn’t running in the background. I could try reloading the driver but I’m not having any trouble using JRiver. I would think that if JRiver works, Roon should as well.

Ok, reason I asked is I cant have Tidal and Roon run at once on my PC as Tidal will lose connection with DAC.

I used to have a HA2 (same DAC chip) which worked fine with Roon but that was on a Mac.

Things I would be trying:

Check firmware on 105D
Check power on order? ie try switch on Oppo before/after opening Roon or before/after restarting core?
Try a roon remote install on another pc or laptop to see if it works differently.
Change the DAC in Jriver to system or something else or remove it.
With everything on and Roon open, what happens when you plug/unplug USB cable?

Hey @Richard_Grant – just saw your PM, did you make any progress here?

Could you provide screenshots of your audio device’s settings as described here?

I’m going to move this thread over to the Support area so we can make sure you get this resolved. Just flag @support when you get us the screenshots, and answers to @Steve_C’s questions above. Thanks!

1 Like

OPPO Firmware version BDP10X-83-1226
When I unplug the USB the OPPO play zone in Roon disappears then reappears when I plug it back in, so it is recognizing the OPPO. I also have Roon running on three different remotes, two Android devices,and a Win 10 PC with the same results; not sound. The OPPO device driver in Windows is
I tried different combinations of startup i.e. Power down/up OPPO with Roon running, restart Core PC with OPPO powered off and on, and restarted Roon with OPPO off and on.
Currently running Roon version 1.3 (build 209) stable (64bit)
ASUS VivoPC sries
Intel Core i3-4030U @ 1.90GHz
4 GB Ram
64 bit Windows 8.1
Roon settings:
Device setup General tab: Private Zone, No; volume control, fixed volume
Playback tab: Max hardware buffer, no; Max sample rate, disabled; DSD playback strategy, convert to PCM; channel layout, 2.0; Multichannel mixing strategy, downmix as needed.
Network Info:
Music stored on western digital Mybook 2TB connected to network by Ethernet
Core computer connected by Ethernet.
I can play music with the current system configure using JRiver so all integration seems to be working.
The OPPO shows upin the Roon settings twice; once as OPPO BDP-15(D) USB Audio 2.0 DAC and as OPPO USB Audio 2.0 ASIO Driver. Tried disabling and enabling both and separately.


Hi @Richard_Grant ---- Thank you for the follow up and taking the time to provide the requested feedback. Both are appreciated!

I want to take step back for a moment, to just verify a few things with concerning this behavior being reported. When the devices fails to playback audio, do you receive any error messages in Roon? Does playback look like it’s going to start but appears that it get’s stuck on “00:00”? Does it start and then immediately stop?

Furthermore, have you tried using exclusive mode, when using this device?


Hi, Thank you for the response! Sorry, I should have chosen words more carefully. The music play but there is no sound. It does show in Roon the music is playing. I can pause and play and the curser advances along the time line as the music plays. Yes I did try exclusive mode but that did not help either. This is quite frustrating; I seem to be the only one having this issue. It should be very simple. I know the USB connection is working because I can unplug the USB cable and the OPPO play zone disappears and comes back when I plug the USB back in. Also the music plays with JRiver.
Thank You

Not sure if you got my response to the questions you asked. I did respond to support and I am continuing to troubleshoot.


If you enable system output on your PC can you get sound out of the PC speaker? Still not sure if this is a Roon or Oppo issue.

What’s the “Media” zone connected to your core? Try and have only one zone enabled while troubleshooting.

Can you show a screen shot of the audio path when “music plays but no sound” as you say. You click on the purple dot to get your path.

Another idea, can you connect the Oppo to the PC instead of the core and see if that works?

The Media zone you see is the PC I use for the Core. I took two screen shots to show the path and current audio setup for the OPPO. I also uninstalled JRiver, but that did not help. I enabled the Core as a zone to play through but got no sound. I attached three screenshots.
Thank You!!

Tough one. You should have audio. The purple indicates bit perfect transfer.

So have I got this right?

If you play via JRiver to the Oppo via the Wasapi USB driver you get music.

If you change nothing else except you play via Roon to the Oppo with the same driver and no change in USB and no change in Oppo you get no music?

Yes you have that correct; I can play music via JRiver but when I close JRiver and try to play through Roon with no other changes, I get no sound. I uninstalled and reinstalled the OPPO driver again but no change. Very frustrating; this should be very simple. I’m not even sure where the problem is. I know my USB connection is good because JRiver is using that path. Windows is reporting all is good with the OPPO and driver. I’m curious about one other thing. When I go to manage audio devices in Windows and choose OPPO configure, there is a button you can click to test the sound, but when I do, there is no tone heard.
Right now I’m upgrading my Core PC from Win 8.1 to Win 10. I know it’s a stretch but It’s something I’ve wanted to do anyway. I like Roon and really want to use it but currently it only works with my phone and tablet devices and I really need it to work with my OPPO to listen to music on my best sound system.
The system I use is ASUS Media PC (core), OPPO BDP-105D connected to REGA Elicit-R amplifier connected to Klipsch Cornwall III speakers. Very simple system.
Thanks You!!

To isolate the problem to either the Oppo or Core PC. Can I connect the Oppo to a laptop that I use as a Roon remote to play through the Oppo?

Yes, add any necessary drivers and don’t use a USB3 port unless you have no other options. I have a Teac DAC that fails to silence when using a USB3 port but is fine with USB2.

Currently, my core PC is connected to my Oppo DAC via USB 3.0. However, that has not given me any problems using JRiver. Maybe it is a problem with Roon?

Hi @Richard_Grant ---- Touching base with you here, thank you for the screen shots and confirming the exact behavior you are noticing!

Have you tried mounting the Oppo to the other laptop yet acting as a remote? If so, what was the outcome of that test?

Looking forward to your feedback!

I finally had time to test the Oppo. I just grabbed any old USB cable and connected from my RPi2 to the Oppo105. Roon showed the new zone immediately. Press play and we have music no issues. I just wanted to make sure the Oppo works with Roon. Hopefully you have more luck with the other machine or another cable.