Cannot Play Tidal Tracks nor Login to Tidal from Roon

Hello Roon Support,

Starting this morning I have experienced issues playing Tidal tracks via Roon. When attempting to play Tidal tracks I would received an error stating that the track is unavailable.

I tried disabling Tidal in Roon settings and logging out, then attempting to log back in but now Roon will not even log into Tidal. I received a “Network error: please check your connection error.” All other applications that use the internet connection however work fine. A few further details:

  • Roon core version is version 1.5 build 339
  • Logging into Tidal outside of Roon works fine, whether using the browser or iOS application
  • Roon core is running on an iMac late 2015 i5
  • Roon remote is version 1.5 build 339
  • I have tried logging into Tidal via settings in Roon remote and directly from the Core machine
  • Playing local files in Roon works fine

I have seen two other support topics today mentioning similar issues today. Let me know if you need any further details.

Thanks for reaching out, @BWQ!

So we can better understand what you’re experiencing here, please verify the following:

  • Since noticing this behavior have you tried power cycling your Core machine? Often times a reboot will help with TIDAL login difficulties.
  • Once logged in, are you able to play music from TIDAL without issue? If you go to your TIDAL account > subscription settings, can you verify that it is showing your account as active? What region is your TIDAL account for?

After rebooting and confirming that you’re able to play from the TIDAL app/webplayer with an active subscription, please try the following:

  • Close Roon
  • Find your Roon database
  • Delete the tidal_account file (Database > Registry > Core > tidal_account).

Once you do this try to login again and let us know if you’re successful.


1 Like
  • I will try rebooting the machine
  • I am able to play music from Tidal outside of Roon and the subscription is showing active. My Tidal account is based in the US.
  • I will also try deleting the Tidal database registry.

I will let you know my results.

1 Like

Clearing the database registry did the trick, thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.