Cannot play to airport express group in sync

Hi @Noris, it just happened: I started playing from History and at the beginning of the second song, AppleTV and Airport 2 were out of sync.

Hi @Marco_Sassone,

What was the approximate local time that this occurred? On what track did the devices get out of sync?
Please be as specific as you can as this is useful when cross-referencing logs.

ouch! I wasn’t aware of that… before going for Roon life subscription I read this and thought it was enough. I tried it, tested the Airplay grouping and as it worked, I went for the subscription.

Hi @noris,
History shows it occurred 1 hour ago, so 7:15 pm here in Italy, at the beginning of Every Breath You Take by The Police (mp3 320 kbps file), just after playing “The Universal” by Blur (ALAC m4a file).
They both reside in Roon Optimized Core Kit Internal Storage, and were randomly picked by Roon Radio.
I just played the same sequence again and it went smoothly, with no out of sync …

I might jus add:
went for checking on difference of DSP settings and found that Sample rate Conversion was Enabled in AppleTV and Disabled in the Airport 2. As two different settings in a grouped devices don’t seem a good thing to me, I Disabled in both. Now waiting for any changes …

Airplay devices per se are not the issue it’s with airport networking that issues have been noticed. For some they work just fine but others have had issues. Ymmv

Thanks for the timestamps @Marco_Sassone. I’ve activated diagnostics mode for your Core and what this action should have done is automatically upload a logs set to our servers.

I have been keeping an eye out for the logs but they don’t seem to be uploading. Can I please ask that you use these instructions to manually send me a set?

The best way to get the logs over would be via a shared Dropbox / Google Drive link, but if you don’t have either service just let me know and I can provide alternate upload instructions.

Thanks!

@noris, zipped Logs sent via message

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Marco_Sassone,

It looks like your thread was accidentally closed, so I have re-opened it so we can troubleshoot this further. At the start of the thread, you mentioned that you previously had a Mac Core which did not exhibit this issue.

Could you please try switching back to the initial Mac Core or your wife’s MacBook Pro as the Core, have it connected the same way as ROCK currently is (same Ethernet cable) and verify if the issue occurs then? To switch the Cores you can use these steps:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi @noris,
sorry for such a late reply, I’ve been busy with other issues and today I was going to try your suggestion when I found the new update to build 536. And since update, after a couple of hours of continuous playing, the out of sync hassle hasn’t happened. Could it have made the trick?

For the time being I’ll keep playing music and leave the troubleshooting to and if it occurs again ( also because moving the iMac close to the NUC Ethernet cable is impossible and my wife is on her MacBook all the time with the online teaching and all. I should install a new core n my MacBook Air).
Should the problem arise again I’ll let you know. For now, thanks for your help.

1 Like

Hi @Marco_Sassone,

No worries on the delayed reply, and happy to hear the new build is working out nicely!
Do let me know if there are further issues and if there are we can certainly continue troubleshooting further.

Is the 169.254.x.x a real issue I need to try and resolve?

I have (3) airport express (bridge mode), i.e., wifi turned off, directly connected via ethernet to my main Xfinity router. (I just added a 3rd one to the system and noticed the 169.254.x.x issue).

Via the Airport utility / xFinity app,all three show a 10.0.x.x IP address, but via the Roon Audio Setup, I can see the 169.254.x.x.

I’ve rebooted the NUC core running Roon ROCK.

So, far…the (3) APE seem to be working as intended (able to play music and link), but wondering if there is something ‘wrong’ with my network setup so that is preventing Roon from seeing/utilizing the 10.0.x.x IP addresses.

hi @Junior77 , I always had the same problem (see screenshot) and never found or given a solution (see previous posts). I guess (from my limited knowledge on networks) that Roon picks up and shows the default IP given by Apple to the Express(es) 169.254.x.x instead of the ones I chose for them (10.1.x.x.), whereas the Apple TV always got the right address…
Since the system has been working, bar the rare droput or out-of sync I could live with, I gave up worrying about the issue.