Cannot play to audio devices on macOS 1208 clients

Roon Core Machine

Linux Core, build 1208 (earlyaccess) although same problem occurred when I was running release. I tried earlyaccess in an attempt to fix the problem.

macOS client, build 1208. macOS Ventura 13.1 and 13.2 tested. Both Intel and Apple Silicon.

Networking Gear & Setup Details

Ethernet to server. Ethernet and WiFi to various clients (problem is reproducible on multiple macOS machines)

Connected Audio Devices

System Audio, CoreAudio, and USB connected DAC. Same problem.

Number of Tracks in Library


Description of Issue

Unable to play back any audio to any macOS build 1208 clients. I have a single build 1182 machine (macOS 13.1, Intel) on the network which still works for playback, even from 1208 clients acting as a remote.

I tried completely uninstalling and reinstalling the Roon client, including deleting ~/Library/Roon, no change.

client error log sample:

02/11 16:33:57 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/423 sec
02/11 16:33:57 Info: [centro] [zoneplayer]     Open Result (Playing):Result[Status=Success]
02/11 16:33:57 Info: [centro] [zoneplayer] Starting playback
02/11 16:33:57 Trace: [centro] [zoneplayer/raat] StartStream Sooloos.Broker.Transport.RaatZonePlayer+Endpoint: StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False) => StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False) streamid=930874702
02/11 16:33:57 Trace: [System Output] [raatclient] SENT [8]{"request":"setup","format":{"sample_type":"pcm","sample_rate":44100,"bits_per_sample":16,"channels":2,"sample_subtype":"none"}}
02/11 16:33:57 Info: [zone centro] OnPlayFeedback Playing
02/11 16:33:57 Trace: [centro] [Inactive] [PLAYING @ 0:00] Take You With Me - Susan Gibson
02/11 16:33:57 Trace: [System Output] [raatclient] GOT [8] {"status":"DeviceOpenFailed","message":"RAAT__OUTPUT_PLUGIN_STATUS_DEVICE_OPEN_FAILED"}
02/11 16:33:57 Trace: [centro] [zoneplayer/raat] device open failed. stopping stream
02/11 16:33:57 Info: [audio/env] [zoneplayer -> stream] All streams were disposed

Correct me if I am wrong, but I thought we were told (especially for earlyaccess) that all clients NEED to be on the same build for them all to work. If I am understanding what you said above correctly, you have one client that is on an earlier build. Can you just update that one to 1208 to see if the issue goes away?

My MacBook Pro is running on the latest version of Ventura. My MacBook Air on the latest Monterey. My gaming laptop on Windows 11. And my Roon Core runs on a Lenovo laptop running Zorin Linux Pro.

All of them are running the latest production version of Roon and all endpoints are playing as they should.

I was reluctant to upgrade the only client I have remaining that is able to function. If the single older version client is powered down it does not fix the 1208 clients. Build 1208 is not early access and I only upgraded the server to early access in an attempt to make things work again.

1 Like

Just to clarify, you are using macOS audio devices as endpoints in your setup?

Normally not, since both my Mac’s have a dedicated USB device attached to them. But as a test I’ve enabled the speakers on my MacBook Pro. And it plays without problems.

M1 MacBook Pro, 8 gb RAM, 256 gb SSD, macOS 13.2 Ventura.

Thanks. I guess I’ll tear it all down and do a clean install here to see if that helps at least this issue

Did a clean install and now I can’t reproduce this. Thanks, everyone!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.