Cannot reach Roon Nucleus on Network

Core Machine (Operating system/System info/Roon build number)

latest (not sure, I cannot use the IP to enter Nucleus configuration utility

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi Dream Machine Pro > Unifi 48 Switch > Roon Nucleus (192.168.55.47) > Unifi APs for Chromecast

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

3 Chromecast gen. 2

Description Of Issue

I am unable to reach the nucleus configuration utility. I was trying to configure Chromecasts on a subnet (55) and so had all streaming devices on that subnet per UNIFi whitepaper (https://help.ui.com/hc/en-us/articles/360001004034-UniFi-Best-Practices-for-Managing-Chromecast-Google-Home-on-UniFi-Network). I could not see chromecasts in Roon and was trying various network settings. Then Roon was unable to find the core. I tried to acess the Nucleus configuration utility, but I cannot do that either now. Nucleus is now on 192.168.55.47, which is believe is incorrect. I beleive it should be 192.168.1.47, but I am unable to access the nucleus configuration utility at all. I have restarted Nucleus many times but it always appears on the subnet and I cannot reach it. I can ping 192.168.1.47 fine, but when I ping 192.168.55.47 50% of packets are lost. Basically there are two problems here Nucleus and Chromecast, but Nucleus first. Any ideas?

Someone will assist you from support in due course…sit tight. Maybe change your network back to the 55.xx range and set the nucleus to dhcp and not fixed. Use address reservation in unifi to fix the nucleus address if you want it on a specific address…note all roon devices need to be on the same subnet to see each other … including the CC units

I would like to change it back to default, but I cannot access the Nucleus web-interface. Let’s start there.

you could try to set your pc/Mac to a fixed address in the same range as your NUC say 192.168.55.44 and connect the lan cable direct to the NUC then see if you can use the browser to http://192.168.55.47 to get access then reset it back to DHCP and save then put everything back to DHCP on the PC/MAC and connect back via the router

Hi @peter_derousse,

Did you set a static IP on the Nucleus? If so, can you connect the Nucleus to a monitor via HDMI and a Keyboard via USB? After this type press ENTER , type resetnetwork and then press ENTER again. This should reset the network settings for you.

1 Like

Thanks for the assistance. I was unable to access roon either by connecting it directly to a PC or through HDMI to a monitor. Image 1 is HDMI on start up, 2 is shutting down, 3 is last screen before going dark and cycling again. It appears to be stuck in some kind of loop. IMG_3658 IMG_3659 IMG_3660

Have you enabled DHCP on your network?

yes. Many other devices have ip on this network.

What version of Unifi controller are you using ?

Should not matter I have used Unify for 3-4 years and never had ROCK issues. I would reseat the RAM and SSD and also if this is a brand new unit seek help from the selling company as you could have a defective unit.

Ok, I was able to resetnetwork to 192.168.1.47. I can ping this address and Unifi Controller shows the device; however, Roon does not connect with it and I cannot access the nucleus web interface. I have also tried it plugged into the back of a pc and Roon will not connect with it there either, also no web interface.

Ok, I resolved the connection to Nucleus issue by reinstalling Roon. Thank you for the help.
I still cannot connect to the 3 Chromecasts. I have used Unifi’s suggested settings (https://help.ui.com/hc/en-us/articles/360001004034-UniFi-Best-Practices-for-Managing-Chromecast-Google-Home-on-UniFi-Network), which up until 2 weeks ago worked without problem for quite some time. I’ve made a new subnet (50) for a new wireless network, and still no go. Any ideas?

Um - don’t have a separate subnet? It’s all very well for Unifi to recommend that you have a separate VLAN for Chromecast devices, but Roon Labs best practice has always said don’t have separate subnets - it breaks the auto discovery process.

I’ve never seen this before and have been using the above setup since Nov. 2018. I don’t believe Unifi is suggesting putting Roon equipment on subnets separate from Chromecast.