Cannot Remove Phantom Album

Let’s get it out of the way. I do not like 1.8 One more reason is that it scrambled all the Frank Zappa six YCDTOSA sets, that I had painstakingly added and arranged. I copied all of them to my PC from my QNAP NAS, so I could re-add them to my library. I deleted the files off the NAS and removed them from it’s recycle bin. Still vol3 will not go away. I tried disconnecting the drive and re-scanning. Still there. I tried cleaning up the Library. Still there. In fact, it even shows that the 148 tracks that it somehow mashed all the discs into vol3. are still there, but it won’t remove them. I’ve restarted Roon. No luck. I now have an empty library waiting to be repopulated, but I don’t want to do anything until it’s gone. File location shows “Local”. This simply should not happen. Another 1.8 bug as far as I’m concerned.

Somewhere in setting there is something like dB clean option (sorry can’t remember exactly).
Do that and restart core.
Helped me with the similar problem.

Settings → Library → Library Maintenance → Clean Up Library


That’s the one :slight_smile:
Thanks Michael.

Yes, unfortunately, I’ve all ready tried that to no avail. Despite seeing those 148 items as “not being associated with a storage location”, this function will not remove them. I don’t even receive a process message - it just fails. Oh, and 1.8 also deleted all the custom album covers I had added. Fortunately, I created a separate folder for them. I spent hours and hours fine tuning my dbase, and then, boom, 1.8.

In addition to above, I disabled existing data folder path and added “new” folder path.
The existing was direct path (created with browser) and the “new” was pointing to the same location but as a samba share. Have a look at this post, especially the last post:

Maybe that was the real fix…

Hey, I’ll give it a shot, thanks!

A restart of the NAS was the cure! I was then able to remove those pesky 148 items. Now on to rebuilding…

Glad you sorted that out :slight_smile: Now back to Rock’nRoll !

PS, since my problem I always stop core before adding/deleting files. It never failed since.
Both our problems include NAS so maybe the NAS is the problem in general.

1 Like

Interesting. Yes, essentially not allowing it to process any data until after the file alteration on the NAS. A shame but if it saves some frustration… Thanks for the assist!