Cannot see my account; red warning that I'm not up to date

Mac version of Roon, version 1.7 build 537 stable.

Clicking on ‘account’ spins for a long time and then gives an error

Metadata improver claims that I need a software update, but none are available.

And my machine is blowing its fan, just to add to the fun.

Hi @Benson_Margulies
Others that have reported this have that found the rebooting the Roon core helps.
Give it go and see if works for you.

No such luck here. I got a CPU spike (cured by flipping Wifi) but no lack of red triangle.

Hi @Benson_Margulies,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Was there any change to your setup around the time this happened?

Roon runs on a Mac Mini 2018) with 32G of memory. The Mac has a wired connection to the router. The Roopieee is on Wifi. Music live on the Mac’s main hard drive. It’s all very simple.

The only change in the world is the addition of the Roopieee in my living room.

Hello @Benson_Margulies and thanks for the detailed information. If you change to Google or Cloudflare DNS does anything change? What are you using currently?

I was using the default from Centurylink via my router, I’ve switched to Google’s and nothing changed.

What host tries to get resolved when I click on account? I could try ‘dig’.

Hello @Benson_Margulies and thanks for testing this. I would like to get your logs over to my team for further review. Here’s what we’ll need to do:

  1. Restart Roon and get the metadata improver message again, please let me know what time (your local timezone) you do this.

  2. Use the directions found here and send us over a set of logs using this link.

From there I will pass your info to our team for further analysis. I would like to continue troubleshooting the account access issue though, as they might not be entirely related.

  1. When did this start happening?
  2. Have you made any recent changes to firewall or antivirus? Can you disable them temporarily and see if that helps?
  3. Can you tell me more about your network environment, what route you’re using, any switches, etc?

Thanks for the info!

Both created at about 8:14PM pacific on May 29th. The red triangle had not yet appeared in the roon-logs set, it’s there in roon-logs-2. In neither case can I access my account.

I don’t know precisely when this started. Nothing has changed in firewall or AV that I am aware of. I don’t run an AV, and my ‘firewall’ is whatever my netgear does. I would much prefer if you tell me which addresses and ports you need to reach.

Network environment is CenturyLink fiber, a netgear router, and power-line ethernet from the router to the mac that runs the core.

An interesting log message:

05/29 20:16:32 Warn: Error in web request NetworkError (The request was aborted: The request was canceled.)
05/29 20:16:32 Warn: [additionalimages] networkerror downloading performer image for 122:0:MN0000079523: Result[Status=NetworkError, ErrorText=The request was aborted: The request was canceled.]

I can access that URL from a browser with no problem.

With the wonders of tail -f, here’s exactly what happens when I try to see my account.

05/29 20:18:31 Debug: UI-NAV: settings
05/29 20:18:31 Trace: [broker/accounts] refreshing account info for email='' userid=a2b33666-9068-439a-8a47-40240b33d37a
05/29 20:18:31 Trace: [fiveaccountserver] POST
05/29 20:18:31 Trace: [fiveaccountserver] BODY token=5f418a5b-e74f-4c3d-ae5b-386c369cabf1
05/29 20:18:31 Debug: GMS: done saving nav stack
05/29 20:18:34 Trace: [broker/accounts] refreshing account info for email='' userid=a2b33666-9068-439a-8a47-40240b33d37a
05/29 20:18:34 Trace: [fiveaccountserver] POST
05/29 20:18:34 Trace: [fiveaccountserver] BODY token=5f418a5b-e74f-4c3d-ae5b-386c369cabf1
05/29 20:18:41 Trace: [roonapi] [apiclient] CONTINUE Changed {"message":"Running (10)","is_error":false}
05/29 20:18:43 Trace: [broker/accounts] [heartbeat] now=5/30/2020 3:18:43 AM nextauthrefresh=5/30/2020 4:08:43 AM nextmachineallocate=5/30/2020 7:08:43 AM
05/29 20:18:44 Info: [stats] 7097mb Virtual, 550mb Physical, 143mb Managed, 66 Threads,  FDs


05/29 20:20:14 Warn: Error in web request NetworkError (The operation has timed out.)
05/29 20:20:14 Warn: [broker/accounts] failed to refresh account info: Result[Status=NetworkError, ErrorText=The operation has timed out.]
05/29 20:20:14 Info: [stats] 7102mb Virtual, 554mb Physical, 157mb Managed, 69 Threads,  FDs

Mac firewall is off.

All the things that get errors from roon making network connections work fine from a browser.
I can’t find any setting in your app for a proxy or some other network thing.

bensonmargulies@puck Logs % dig

; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10738
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;	IN	A


;; Query time: 4 msec
;; WHEN: Fri May 29 20:23:31 PDT 2020
;; MSG SIZE  rcvd: 137

I checked network settings; no proxies are configure in there.

To summarize: Room core is logging network errors using HTTP to access web services and images. Those URLs are perfectly accessible from chrome. and also from curl, I tried. Only roon itself manages to get these networking errors.

So I suspect that 10.15.4 is somehow a problem for roon.

Hello @Benson_Margulies, I’m going to meet with my team tomorrow and discuss this issue with them but I had some questions for you!

  1. Do you still have this issue after updating to 10.15.5?
  2. Can you give me a detailed description of your network setup? The model of your router, etc.?
  3. What browser are you using to access that URL?
  4. Have you tried a different core temporarily to see if you have the same issue?
  5. Have you tried bypassing your network and using a hotspot or USB tethering?

Let me know!

I fixed this last night. I had attempted to set up IPv6 on my router. I thought I had it working. I was wrong. When I turned it back off, everything got better. Sorry about all the noise.

All good @Benson_Margulies, glad things are working again! Let me know if you need help in the future. Oh and are you still getting the metadata improver message or did that go away also?

No more red triangle.