Cannot see Roon Server Linux

Thought I should give the Linux a try.

Did a Install on my 16.04 desktop


Unpacking RoonServer_linuxx64.tar.bz2…Done

Checking to see if RoonServer can run on this machine

Checking for Binary Compatibility                            [   OK   ]
Checking for ALSA Libraries                                  [   OK   ]
Checking for ffmpeg or avconv                                [   OK   ]
Checking for the mount.cifs command                          [   OK   ]
Testing ulimit -n 8192                                       [   OK   ]


Copying Files…Done
Failed to stop roonserver.service: Unit roonserver.service not loaded.

Installing /etc/systemd/system/roonserver.service

Enabling service roonserver…
Created symlink from /etc/systemd/system/ to /etc/systemd/system/roonserver.service.
Service Enabled

Starting service roonserver…
Service Started

All Done! RoonServer should be running on your machine now.

But my roon remote cannot see this device.

How can I troubleshoot this ?

You should be seeing a RoonServer process and a RAATServer process running. If you aren’t then it’s worth checking the /var/log/syslog/ and /var/roon/RoonServer/Logs/RoonServer_log.txt files for errors.

If the processes are running then do you have a firewall setup on your desktop? That could be blocking the remote’s connection to your core. If so then try disabling it and see if your remote can connect.

I guess there is a FW default in Linux running, but the install script should either fix that or state which ports required to be opened.

Is there a documentaion about the FW openings required ?

Thanks for reaching out, @bwa!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

What kind of remote device are you using? Have you tried multiple? Are they all unable to connect?


Try turning off Ubuntu Firewall temporarily:

sudo ufw disable

If this resolves things we need to set up some new rules.

That ! Martin is a good advice. You have clearly understood that I have a problem, and what I have done and what advice I need.

Dylan tries to overcomplicate it with a lot of nonsense. Sorry Dylan …

So I disabled the FW and now I can connect.

So the install scrip and the Installation guide need som more work. Hopefully someone can do that, as I’m clearly a Ubuntu neewbie

Okay, you’ll need to add some rules to your firewall. I found this a little bit hit and miss, but the following should get you up and running.

sudo ufw allow 9100:9200/tcp
sudo ufw allow 9003/udp
sudo ufw allow 80/tcp
sudo ufw allow 443/tcp
sudo ufw enable