Cannot seem to access my NAS music data when I have also connected to QOBUZ

I seem to have set it all up well on my QNAP TS 473A - Roon core is there and is working with my quobuz - I also identified my music data folder on the NAS. But one thing - well two really - I can readily play Roon using QOBUZ on my NAIM streamer - BUT it seems to pick up what I have identified as favourite albums not the ones I have bought - do I just have to make these favourites as well? - but once I have set QOBUZ I cant then seem to also be able to access my music file on the NAS (I did set it as a source when I first set up ROON core on the NAS.

Moved to the support area.
Have you pointed roon at the storage where the qobuz downloads are?

Yes I did
But I then linked my Qobuz
The query is can I point both to myQobuz AND to the music file on the NAS where I have my downloaded music stored so I can draw on both or is it one or the other

You should be able to set Watched Folders in Roon to include local content in your library and have your Qobuz favourites integrated into your library.

If you have purchased albums/tracks from Qobuz, then presumably you have downloaded them to local storage somewhere (on your NAS?). The root folder of those downloaded albums/tracks should then be set as a Watched Folder in Roon to include them in your library. No need to also set them as Qobuz “favourites” in Qobuz - this will just have the effect of adding the streamed versions of those albums/tracks into your library - so you will then have duplicates…

Will try that
I’ve just got into Roon love it but a wee bit naive

Thanks for the pick up on the other post
Didn’t realise I’d posted that one

Feel free to ask questions in the forum, the community is helpful. There’s also the Knowledge Base, which is worth browsing…

1 Like

Well - I have reset everything and clearly linked the Roon server to Qobuz AND the file on my QNAP where the music is stored and I can see it there - but Roon will not see this even though it is clearly a folder that is identified (if I try and set it again it says this folder is already a watched folder
Frustrating and cant seem to find similar issue in community - a bit of a frustration as I say because I am wanting to become a lifetime member but of course not if I cant access my saved music file


Can you post a screenshot of Roon’s Settings > Storage screen? It is the one that looks like this…

Welcome to the Roon community and have a happy and (re)sounding new year, Steve!

Maybe showing hidden tracks and albums as per screenshot helps…

Here it is

Thanks Marin
Happy new year to you all too
Yes my page looks exactly like this

The fact that it says “Watching for new files in real time” suggests that something is wrong, e.g. for some reason it is not seeing any valid files there. If you look at my screenshot, you will see counts of the number of files that have been successfully imported.

If you go to Settings > Library > Skipped files, does that show anything?

It says no files have been skipped
PS all files are flac so it’s not an unusual file
A small number of DSD files too
So I have Roon the I have a file called naim on the QNAP which is where the music is stored and I can see all the files there when I open the qnap

Try a “Force rescan” on the Watched Folder (in the “3 dots” menu on the right of the folder path in Settings > Storage).

And you could also check the “Automatic rescan interval” (choose the “Edit” option in the “3 dots” menu) to see what it is currently set to…

Is it a permissions issue on the QNAP? I.e. is it possible that the QNAP has granted access to browsing PCs or Macs, but not to the Roon Server (running on the QNAP)?

I’ve tried force rescan already - just tried again- nothing
Intestingky I do NOT have automatic scan - as u can see in the image there is nothing after ignore paths

I will check permissions on the qnap

Although as u can see I can see my music files

Steve, there’s a long thread on this issue of Roon Server on QNAP not seeing music files, and it does seem to be a permissions issue. Also varies according to what version of the QNAP OS is being used I think. I don’t use a NAS, and my Core is on a ROCK/NUC system, so I’ve missed this issue until now.

Take a look at this post and see if it helps:

I spent big dollars on the qnap based on Roon recommendation
Now it doesnt seem to fit - not a good start with my experience with Roon
Might reconsider my planned life membership
Hope this gets resolved