Cannot select or edit name of private zone [Solved]

Running Roon server on W7Pro 64bit machine and remote on two Mac Minis.
Server is Roon 1.1 build 69.

On one Mac Mini 2010 running Yosemite with 1.1 build 69 since updating from build 65 I can no longer select private zone outputs nor can I edit the name e.g. for selecting USB connected DAC when clicking on Enable - instead the settings cogs only appear.

On my other Mac Mini 2012 running Yosemite with 1.1 build 65 on same ethernet network I am not having this problem - same basic lineup with USB DAC selected as private zone.
Your help to resolve this is appreciated.

Hey @Stuart_Frazer – sorry for the trouble here. Can you post a screenshot of the audio tab of Settings on this machine:

We can look into this further, but it might be worth trying to reinstall Roon on this machine – other than a few preferences, the vast majority of your Roon settings are stored on the Core machine, so a quick reinstall may be the fastest way forward here.

Hi Mike,
Screenshot of audio settings attached:

I have already tried fresh install but no joy.

  • are there any hidden files I need to remove?
    Also tried install on different userid on same machine and got a “Key Lock Error” message.


Hey @Stuart_Frazer – sorry for the slow response here. When you say you’re trying a fresh install on the remote machines, are you deleting (or renaming) the entire Roon database folder? If you’re not doing that, I would still recommend starting there.

Keep in mind that I’m suggesting you wipe out the Roon folder on the remote, not on the Win7 Server, which would actually wipe out your settings, playlists, edits, etc.

Anyway, I just tired to reproduce the setup you describe – I got a Win7 Core running, and an OSX Remote, which i updated from Build 65 to Build 69. I had no issues renaming the private zones before or after, so it looks like this is something specific to your install or environment. If you’ve already been removing the database on the troublesome remote install it’s likely something to do with your environment – we just need to figure out what that is!

Let me know what you’ve tried so far and we’ll move forward with gathering more logs and looking into your install further. Thanks @Stuart_Frazer!

Hi Mike,

Many thanks for your help – my lack of OSX skills meant that I missed the step of deleting the Roon database folder when trying re-install.
Having now done this system is up and running and I can select the Mac devices just fine.

Kind Regards

1 Like