Cannot setup 2 ROCKs: One as a server/core and the other as an endpoint


I have been running ROCK on a NUC8i3 flawlessly. Last week, I bought NUC8i5.

I installed ROCK and transferred my database to the NUC8i5. All went well. I am going to use NUC8i5 as my Server.

I reinstall ROCK on NUC8i3 and it went well as well. I want to use the NUC8i3 as an endpoint.

NUC8i5 has a dynamic IP of
NUC8i3 has a dynamic IP of

I connect the Remote to the NUC8i5 which connected fine but I could not see Roon on NUC8i3 on my Roon Remote.

I tried to connect the Remote to NUC8i5 which showed me the Roon Login or Sign Up page. I typed in my id and password, but it told me that I am already signed in as if I wanted to create a new Core. I canceled this process and connected back to the NUC8i5 server.

How do I set them up so that NUC8i5 as a server/core and NUC8i3 as an endpoint? Did I miss anything? I installed NUC8i3 the same way as I did NUC8i5.


I believe you must install one core (this will be the server) and one bridge (this will be the endpoint), and not two cores.

Sign out of the one you wish to use as an end point. It doesn’t require your sign in to work and shouldn’t have any library data on it.

I thought ROCK can act as both a Server and/or an Endpoint? I did not know how to setup ROCK as an endpoint if that what you were suggesting and what I was missing.

1 Like

I never signed in to NUC8i3 and NUC8i3 has no library at all.

I should have added these screenshots on my original post. I wanted to edit the post, but I already saw 2 replies. This is a very good, active and helpful community :grinning: :grinning: :+1:

Oh, and I did restart both ROCKs. In fact I restarted twice but nothing changed.

Hi you only sign into one device. ON the device you signed into you goto settings and audio and select the other one as a playing device, assuming you have connected the other one to a dac.

You can also rename your ROCK devices so I’d go in and change your endpoints name.

I have not connected the endpoint NUC to a DAC. Is it a prerequisite for it to show on the remote?

How do I rename it since I could not see nor access the endpoint from the remote? Can you elaborate?


Hi yes it has to be connected to an audio device otherwise it wil no show can you connect the endpoint to a dac?

Once you do this it will appear in audio settings as a device which you then enable and give it a name


As it’s currently set as an server I think you have to log into it from a browser and tell it not to be

Do you have the 2nd Rock connected to a DAC? It will only show up as an audio device with a DAC connected and powered on. I have been using 2 Rocks for a long time one as server one as endpoint without any issues.

1 Like

While this may work, it seems like a strange thing to do. A $35 Raspberry Pi running RoPieee (or similar) will perform better as an endpoint. The RPi will also use less power and produce less (zero) fan noise.

I’d suggest that you use your 8th gen i3 NUC for something more interesting.

1 Like

Since you have backed up your Roon library that was on your old Core and then restored that library to your new Core, just (temporarily) disconnect (or power down) the machine you want to use as an endpoint.

Bring up and set your new machine as Core.

Attach the machine you want to be the new endpoint.

One trick is if you don’t log into the non core rock the only way to update it when the software is available is to reinstall from the web GUI. I too run rock as a bridge solution. But yeah a RPi is much cheaper option.

You were spot on. Yesterday, I brought the NUC to my music room, connected the DAC to NUC’s USB, turned on the NUC and … Voila, just like that, the ROCK showed up as an endpoint. I enabled it and it recognized the brand of my DAC and I chose the appropriate type for my DAC.

I did not have to do anything else beside installing the ROCK on the NUC and connect the DAC to it. It was so simple I was overcomplicating things by trying to overdo the simplicity.

Thank you for your pointer.

Best Regards.


To other members who suggested Raspberry, I do have a Raspberry Pi with a HAT Allo Digione that I used on my headphone system. It shows up on my screenshots.

I tried to use the NUC because I was having a problem with my Bricasti M5 streamer connecting to Bricasti M1 DAC through USB. It runs fine through AES and SPDIF. I suspect it is the M5 that is acting up since it used to work. Last year I contacted Bricasti about this issue and they told me it is probably a configuration issue. However, the M5 virtually does not have user adjustable option. But, that was what they told. So I wanted to make sure that the M1 DAC runs well via USB with another “official” Roon Endpoint.

I might not need the NUC8i3 anymore as an endpoint. But I might as well keep it. Things break and I would like to have a spare and or use it for tinkering my system.

Thank you all.

1 Like

Tinkering is always fun.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.