Cannot Sign- In To Qobuz and Tidal Since Moving To New Home [Solved: Netgear Settings]

Roon Core Machine


Networking Gear & Setup Details

Optimum Modem> Netgear Nighthawk AX5400

Connected Audio Devices

Lampizator Atlantic TRP DAC via USB

Library Size

46960 tracks

Description of Issue

We recently purchased a new home and I can no longer sign-in to either Qobuz nor Tidal.
Error message repeats as saying “Network Error:Please check your connection.”

My subscriptions to both Tidal and Qobuz are up to date. Further I can login to both Qobuz and Tidal using their web browser player, but that doesnt help me get music into my main system.

The only new component into the system is the Netgear nighthawk router. I have enabled and then disabled their security software, Netgear Armor. On or off makes no difference. Still cannot get access to Qobuz or Tidal.

I had Optimum technician over to the house today and he confirmed the connections are correct and he left just as confused as I am.

Currently I can play all of my locally stored files, approx 47000 files, but approx 20000 files I have on Qobuz are showing as “unavailable”

I contacted Qobuz and they are asking me for Roon’s suggested fix.

Please assist.

Darren W.

Have you signed out and in again to the services in roon?

I had not tried that, so I tried it and now im getting the same error message when trying to sign into Roon.
Now im completely dead in the water w/ no access to Roon, Qobuz nor Tidal.

I finally fixed it. The issue was due to the Netgear Nighthawk and the app not setting it up correctly. Once I logged into the desktop version it put me thru more steps that the app didnt do.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.


Thank you for following up here with this update. We’re glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones: