Cannot sign into Qobuz account in Roon Services

Roon Core Machine


Networking Gear & Setup Details

Netgear v7610 + Netgear Orbi.

Connected Audio Devices

  1. Roon Rock NUC → Network → Orchard Audio Pecan Pi → Orchard Audio Strarkrimson Monoblocks → KEF LS50

  2. Roon Rock NUC → Network → Sonos 5

  3. Roon Rock NUC → Network → Orchard Audio Pecan Pi → Yamaha Receiver

Number of Tracks in Library


Description of Issue

I cannot sign into Qobuz inside Roon → Services. I can sign in to my Qobuz account in Chrome and in the Qobuz Desktop Player with my account info. When I try to sign in in Roon I get the following error:

“There was an Unexpected error, please check your account details (UnexpectedError)”

At first I just couldn’t load any content from Qobuz. I got a message that the track was unavailable or something to that effect. I tried to disable, log out and log back in to qobuz and that’s when this problem started.

My Qobuz account is up to date. I can sign into Qobuz in every instance except for Roon.

I have tried restarting my router and it has not helped. I have not restarted my computer or phone since the same problem is happening on both devices.

1 Like

Are you using your qobuz registered email address to sign in to Roon?

Also getting this error as of this morning…

IT’s suddenly working again. I restarted the Core and now it accepted my sign-in. I also made double sure that my Qobuz password was being pasted as plain text by running it through an HTML to text converter.

Could be the qobuz network entry point was down or busy. Roon uses a different address than the native qobuz app.

1 Like

This has been occurring a lot lately with Roon and Qobuz. I have recommended rebooting the Core to many and this has worked. Not sure why this is happening but it seems to have ramped up since the last updates.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.