Cannot sign on to Roon

Core Machine

Network Details

Audio Devices

Library Size

Description of Issue

Roon will not sign in on any of my Apple devices. My Core is on Nautilus. All my Apple devices have the latest operating system.

When I start Roon, I’m asked for my sign-in email and password. I put both in. Then the symbol shows u that says “Connecting to Roon.” But it never connects. It also does not email me a way to reset my password. Not that should be a problem as I type my password correctly.

One day Roon worked. The next day nothing works from my two MacBooks, to my iPad, to my iPhone.

Please help, Sincerely, Michael Davis

Sorry for the trouble here, @Michael_Davis!

I enabled diagnostics on your Core machine and it looks like all attempts to communicate with our servers to log in are timing out. It looks like there is a networking issue here.

Can you describe your network setup? Was there any change you are aware of lately?

My IP signal comes into an Arris modem. From there it goes into a Linksys system which was installed in February of this year. Nothing has changed on it. And no other app is having problems exept Roon.

Best regards, Mike

You might try rebooting your Core. Sometimes weird nonsense gets cleared up that way.

Hi @Michael_Davis — I agree with Kuryan, a Core and network reboot is definitely a good thing to try here.

Are you able to reach the Nucleus Web Administration Interface? Can you share a screenshot of what you’re seeing there?

I rebooted my network and rebooted the Nucleus, twice for both. I still cannot get into Roon.

The screenshots below show what I see. I also took a picture of the upper right-hand corner of my screen showing that I have a network connection. And I went into my Lynksys router and it showed my Nucleus is connected to my netwok. It also showed my laptop is connected to my network.

I did not see a way to connect to the Nucleus Web Administration Interface. It seems I need to download another version of the Roon app. When I did that and opened it, I get exactly the same sign-in screen without access to anything else.

This is frustrating and tiresome because my system is vanilla as they get. Basic Apple devices, up to date operating systems, Lynksys hosted LAN (which not weird and unusual) and I did not build my own Core from soupcans and string, which I know some of your other users can do. Nothing is “off the shelf” more than what I have. So how come it doesn’t work??

Please let me know that to try next.


Sorry for the delayed response here, @Michael_Davis! I’ve been out of the office and I’m working to get back to everyone ASAP!

I enabled diagnostics on your account and it looks like your Nucleus is having a hard time communicating with our servers. It looks like there is a DNS issue at play here. You might want to try setting your network to use Google or Cloudflare DNS. We have information about this here:

It did not help. I changed the DNS settings to both by Arris modem and my Linksys LAN. I used Google, Cloudflare, and OpenDNS in that order.

Following other instructions, after I changed the DNS choices, I rebooted the modem, the Linksys system and the Nucleus. When I had the Linksys router openned, I could see tha the Nucleus was attached to the LAN. The screen shots show exactly what the previous pictures show.

Nothing changed. I still cannot connect. The long attempt to connect ends with an error message that I’m not connected to the internet. And, of course, I am. I tried signing onto Roon on other devices where I have the Roon app. None of them work.

So, what next?

Best regards, Mike

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I had previously identified my problem. I even sent pictures of screenshots. Now I am locked out of viewing a solution to the problem I raised. I did everything tech support recommended, yet Roon does not work on any Apple device I have. Please respond.

Micheal Davis

Hi @Michael_Davis

Apologies, it looks like your original post was marked as “Resolved” so it automatically closed. I’ve re-opened.

Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

I am having much the same problem. When I start Roon on a controller, it takes me to the Login or sign up screen. When I enter my address and password and push login I get the same searching screen that Micheal reports. Then it comes back with a message that “You’re already signed in” with instructions to connect to the Core you previously set up or to set up a new core. Going back to the old core just puts me back on the login screen and there doesn’t seem to be a way to log out the old core to start setting up a new one. The system was working on Sunday and nothing happened with the core since then (except for a reboot). My devices are all macs. There were updates to the device os’s that went through yesterday.

Dylan, There is no folder or file on my Mac for the Roon log.

I can disconnect my Nucleus from the LAN and connect it directly to my Mac and look for the Log file there. But I’m very skittish about messing with things, so I want your concurrence that I can do that to find the Log file.

Best regards, Mike

I had a similar problem running Roon on my NAS, and couldn’t find a solution. Everything worked, and in the middle of a listening session it stopped working and trying to login resulted in a timeout. In my case, I rebooted, reinstalled, updated DNS, all to no avail.

I even Telneted to my NAS and was able to successfully use curl to make a login request, but the Roon core software itself always timed out on that request. Interestingly enough, I could see in the logs that every other network request to Roon servers was successful, just not the login.

This link will get you to my log files.

I have no advice but to let you know I feel empathy and sympathy. Roon must really be “rocket science” because I run some pretty sophisticated programs on my Mac and nothing seems to fail like Rooon does.

For whatever reason, my Roon is working perfectly now. You can close out this action item.

Thanks, Mike Davis

1 Like

I noticed today that Comcast has fixed IPv6 issues and I’m now able to verify IPv6 connectivity through various test sites. Not sure if you are on Comcast or not, but that could have been a possible cause.