Cannot update from 1.8 to 2.0 on my Nucleus +

Roon Core Machine

Nucleus +

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Help, total novice here.

I can use the Android app (v.1.8) to connect to my Nucleus +

I cannot map on my network to my Nucleus. My home theater receivers, Lumin U1, Sonos Move, printer and others show up on my network, but not the nucleus plus.

I tried doing the updated from 1.8 to 2.0 via my IP and it keeps reinstalling 1.8.

Any ideas?

I get frustrated because I feel I’d be better off with just using Tidal into my Lumin U1. Kind of sad.

I’ve linked a 1.8 to 2.0 Migration FAQ. The section you want is RoonOS Core 2.0 (Nucleus / ROCK)

1 Like

It was quite a productive night.

I was able to successfully map to the nucleus plus and manually upgrade to 2.0.

For those who have issues, search the help section and tackle each problem individually. It was not all that hard.

I am not addressing two other issues.

  1. Is Google Cast the only way to display the Nucleus+ visual?
    It would seem obvious that HDMI would display this on my OLED TV, but it seems HDMI is only shows the bootup of the Nucleus.

Anyone have comments?

  1. ARC has been underwhelming. I cannot access it when away from my wifi. I will verify UPnp or NAT-PMP with spectrum on my Sagecom router.

I really wish it were much more simple. These things just need to work.

Updates should be easy. ARC should just work as well.


Hi @Adam_Gorberg,

I’ve marked this topic as solved, if you’re having further issues can you create a new specific topic for them.

However, I’ll make a comment on …

The Nucleus runs Roon Server which is does not support a GUI interface.
If you want a GUI interface you would have to run “Full” Roon [as a remote to Nucleus] on either a Windows or Mac machine and then connect that machine to your TV via HDMI.

Thanks for the info.

I’ll get a google Chromecast. No biggie.

A few things about ARC.

I am proud of myself, as I was able to configure the router to give access when I am not on my LAN.
ARC is working and very nice.