Cannot use WiFi with new Ropieee

I am unable to stream audio using the WiFi connection on my new Ropieee. The wired ethernet connection works. I am able to select the DAC in Roon using WiFi, but once I press play, Ropieee drops out as an endpoint. I am using the built in WiFi. Wired connection is not really an option in the location I planned to use this. Is there something I can do or is there a usb wifi dongle that would work better?

You might want to try a wifi network extender that has an ethernet port you can connect to the rPi. That solved the disconnect problems I was having with my rpi4 running Volumio at least.

1 Like

Thanks for the reply. That’s actually what I am doing, but was hoping for a solution with a smaller footprint if possible. If not, I may have to go that way.

  1. Did you try both 2,4 and 5G bands?
  2. Do you use a metal case that might shield the WiFi signal?

I started having that issue after months of it working perfectly on WiFi. I tried new raspberry, new micro SD card and clean install without luck. The only solution was to use an ethernet cable.

I am using WiFi all the time for several pi end points mixture of 4 and 3 no issues at all. They are all on latest release and WiFi has always been rock solid for me.

I would do a WiFi scan and check nothing is interfering with your ap. You might have a new neibouring network that’s on the same channels and causing too much interference and taking too much of your airtime.

I’m having the same issue with one RPi 4B and Ropieee where I need to use WiFi. It appears in Roon sometimes. Then it drops out. It comes and goes in Roon (Settings → Audio) and eventually disappears completely.

I’m seeing the RPi connected to my router on the 2.4G connection at 54Mbps.

I also have a USB DAC connected.

I started getting similar regular drop outs after updating latest stable Ropieee on both of my RPi 4Bs. No issues with Ethernet. I then tried using my Orbi 750 as access point only with a pfSense box as router and everything runs rock solid again :man_shrugging: .

I was just about to post a similar issue - I have an RPi 4 with HifiBerry Digi+ Pro running Ropieee with the latest update. I had it in a steel case connected via on-board wifi and have been streaming to it from Roon with no problem for several months. Recently it started dropping out when streaming, and as of today Roon no longer finds it as a client at all over wifi. Thinking the case might be blocking the signal I took it out of the case, but the problem persists.

This is new behaviour and comes even though I have changed nothing in my networking and the RPi is visible on the network to both the router and other clients. The RPi is the only network client I have connected to the wifi access point, so it is not impacted by local wifi traffic. I have tried changing channels but also to no avail.

I can ping the Ropieee host via wifi and it comes back in 2-4 ms (this is slow, I think).

When I connect it via ethernet it works perfectly (ping < 1 ms) but I really don’t want to run a cable to where I have the RPi as it takes up a port I need for other purposes. I have the space for a wifi extender but don’t want to get one if the problem is wifi itself, not signal strength due to the RPi’s antenna.

Can others advise their success in this situation with a wifi extender connected via ethernet to an RPi 4?

My RPi is in a Flirc case. I am temporarily using a wired connection which is working just fine. During testing my RPi was in the same room as my WiFi router and the connection was only on the 2.4GHz network at 54Mbps. This didn’t look right. During playback Roon just started skipping songs through a playlist.

At one point I did see a message in Roon about issues with streaming being too slow. I was streaming a TIDAL playlist at the time.

I’m considering a USB WiFi antenna but given that my WiFi router was practically next to my RPi for testing, I’d be surprised if the issue was signal strength.