Cant access ARC despite Nucleus being connected and set for remote access

Roon Server Machine

Here is what I submitted on July 3rd, am posting here in hopes that the ticket is still being worked. I receive an email from contact@roonlabls.com stating: “Thanks, we got your message! Re: [##ARC on my Samsung S21 Ultra cannot connect to the Roon Server, despite the server confirming that it can connect to ARC.##]” but I could not find the ticket number anywhere. Below is what I submitted




:

Hello, for context I have had this issue the entire time I have subscribed to Roon, for over a year. I first started with Roon server on my PC, then two days ago my Nucleus One arrived and I am now using that as the server. The issue is that ARC on my Samsung S21 Ultra cannot contact the Roon Server, despite the server confirming that it can connect to ARC. See screen grabs. The ARC message is “Roon Server unreachable. Check that your Roon server is on and showing ‘ready’”. The server message is “Your Roon Server was automatically configured and has been confirmed to be securely accessible by Roon ARC.”

I thought maybe the Nucleus would allow ARC to connect, but no luck. I tried uninstalling Roon from my laptop so the only Roon devices on the network are the Nucleus and my Samsung, but that did not change anything. I also uninstalled ARC from my phone numerous times.

Computer: Dell XPS

Processor 12th Gen Intel(R) Core™ i9-12900HK 2.50 GHz

Installed RAM 32.0 GB (31.7 GB usable)

Device ID

Product ID

System type 64-bit operating system, x64-based processor

Pen and touch Touch support with 10 touch points

Edition Windows 11 Home Version 23H2

Installed on ‎11/‎17/‎2022

OS build 22631.3810

Experience Windows Feature Experience Pack 1000.22700.1020.0

Network: Verizon Fios 1Gig speed. Router G3100; Fios Extender E3200; Nonmanaged switch KeepLINK KP-9000-9XH-X (8 port 2.5G Ethernet Switch). The switch is plugged into the G3100 router via Ethernet cable; the Nucleus is plugged into the switch.

Audio Devices: Chord Mojo 2 DAC; FOSI D2 DAC

Roon OS Version 1.0 (build 259) production

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Have you tried resetting ARC? On the ARC settings page in your phone scroll all the way to the bottom. It Will say something similar to either “Disconnect from XXX” or “Reset ARC”.

Yes, tried that, and also uninstalling and reinstalling ARC

Hi @Michael_Noyes,

Thank you for your patience in awaiting a response to this request. We’ve taken a closer look at diagnostics and here’s what we can recommend first:

  1. This Nucleus One isn’t visible to our servers and can’t report its status. The Dell is currently the only registered RoonServer instance. At this point, are you using the Nucleus as a RoonServer, or is the device offline? We’ll want to ascertain whether we can’t see the machine’s IP address for the same reason ARC can’t - there’s a redundant layer of network translation or security that is preventing the Nucleus from reliably reaching upstream.

  2. ARC will register credentials with a single RoonServer, and migrating to a new RoonServer without closing an active ARC session can sometimes render the new RoonServer instance invisible to the app. When this occurs, reinstalling ARC is the remedy, as you’ve tried already. However, the reinstall has to occur after you’ve fully migrated to the new RoonServer and deleted the old RoonServer entirely, otherwise ARC will continue to actively associate with the old RoonServer keys.

So, I recommend completing the migration to the Nucleus and then fully clearing the old RoonServer from the Dell after you’ve restored your backup database successfully. Here’s an article overviewing that process:

At that point, you’ll want to reinstall ARC. Try changing the port number in Roon Settings → ARC to something new. We’ll keep an eye on this thread. Thanks!

Connor,

Thank you for the advice. I uninstalled Roon from my Dell, and deleted all the associated databases and folders. I have not yet reinstalled it so there is no Roon server active other than the Nucleus One. I then uninstalled ARC from my phone and reinstalled it. It connected to the cloud and the server right away. However, once I went outside out of wifi range I got the same message of “roon server unavailable.” The cloud connection remained green both in wifi and away from the house. Do you have any recommendations?

And, I soft rebooted the Nucleus One.

Here are my port forwardings:

55005 and 55006 are the Nucleus

Now the ARC wont’ even work via wifi.

Do I need to change any of my security setting? I have Windows Defender and Webroot. Here are some of the Defender settings:

There are no inbound rules for Roon in the Defender settings. I added Roon to the trusted app list, for Private networks.

If you turn your firewall and av off, one at a time you can find which one, if either is the probelm.

I turned Webroot’s firewall off - no change in ARC’s lack of access. Am trying to find the on off button for Defender

I am thinking I will return my Nucleus if I can’t resolve this issue. I can run Tidal just fine on my phone from anywhere, and I can stream Roon just fine from my laptop at home, so having $500 tied up in a Nucleus that does absolutely nothing for me does not make sense.

Hi @Michael_Noyes,
Has there been any change on you ARC settings screen on your server?

Here is what it says

Looks like none of the settings have changed

Wait, the port has changed back to 55002

Is there any way you can remote into my computer to look at the settings?

On your router, you should only have 1 port forwarding rule. And, the port number listed there should match the value shown in Roon, actually MUST match the value. Try removing the rule using port 55005 on the router, and then putting 55006 in the port number area under Settings/ARC.

Otherwise, I would suggest turning OFF UPnP on your router, remove the all previous port forwards and then manually enter one with a different port number: I use 49999. But that Port should be the same in the route rule in the router as well as the number you put into the port number section in Settings/Arc.

I went into the port forwarding page on my router and this is what I saw. The previous Nucleus rules have disappeared!