Can't Access Nucleus Internal Storage

I’m having some trouble accessing the internal Samsung SSD (2 TB, 870 QVO) I’ve installed in my Nucleus Rev B. Specifically, I can see the drive from my Mac laptop (OS X 10.11.6), but whenever i try to access the internal storage folder, either through Finder or smb, I get an error message saying “You do not have permission to access this server.”

Some particular details:

  • I can see the drive through the Nucleus web interface and am able to format the drive to generate the “internal music storage ok” message.

  • I can see the internal storage folder in settings/storage on the Roon remote and make adjustments to settings.

  • The Nucleus shows up in Finder on my Mac laptop (OS X 10.11.6) and I can see the root “Data” share folder. When I try to open the folder, I get an error message that says “The operation can’t be completed because the original item for “Data” can’t be found.”

  • I’ve also tried to connect using the “connect to server” option with the path smb://NUCLEUS/Data/Storage/InternalStorage. This generates a password prompt where I’m asked to choose between connecting as “Guest” or a “Registered User.” If I select “Guest” I get an error message saying “You do not have permission to access this server.” If i try to input a username/password, the same thing happens (i’ve tried my Roon account credentials as well as “Guest/Guest” and “guest/guest” without luck).

  • Finally, I’ve tried to access the internal storage folder via the Files app on my iPhone (iOS 14.4.1), but it won’t let me past the “Data” share folder.

Am I missing a step here? This would seem to be some sort of a permissions issue, but based on what I’ve read here in the FAQs and the boards, it doesn’t appear that credentials are needed to access the internal storage. I have a pile of music I’d like to upload to the internal SSD, but have so far been unable to do so due to this issue.

Any help/guidance/suggestions would be most appreciated. Thanks!

Have you rebooted the Nucleus?

As far as I understand, there should be no password necessary to access the Data share. Nor should you need to use smb. You should be able to get to it via Finder or Windows File Manager.

Thanks for responding so quickly. Unfortunately, I’ve rebooted the Nucleus quite a few times (including just now) and that doesn’t seem to help.

Hi @etr385,

Did you get this sorted? I’ll move this thread to @support to help you out.

Cheers, Greg

Hi Greg,

Unfortunately, I haven’t been able to resolve the issue. I would very much appreciate the move to support.


Hey @etr385,

Thank you for your incredible patience since reporting this issue. I am so sorry it’s been taking us this long to get back to you :pleading_face:

I appreciate you trying all the troubleshooting steps that you have already. In the past week, have you seen any changes?

Either way, I have notified our technical team about this, so they can join in on the conversation and help.

Hi Rebeka,

Unfortunately, the issue hasn’t resolved in the past week. To be clear, I’ve never been able to access the internal storage (or anything beyond the “data” folder) since I got the nucleus in December 2020. I can’t tell if the problem is with the Nucleus itself, the hard drive, or my Mac OS, but it definitely seems to have something to do with permissions. Any help you and the technical team could provide would be most appreciated.


Hi @etr385

On the Nucleus Web Administration Interface can you try reinstalling the OS?

As a test, can you try smb://[IP Address]/Data/ to connect? Is there any change when doing so?

Hi Dylan,

Thanks for responding so quickly. I just reinstalled the OS, but I got the same result.

Whether I try to run smb://Nucleus/Data or smb://[IP Adddress]/Data, Mac Finder still tells me that I don’t have permission to access the server. I’ve tried connecting as a Guest and using Guest/Guest as a username/password. Same result

As before, I’m able to see the Nucleus under “Shared” in Finder and also see the Data folder, but as soon as I click on the folder, it says “The operation can’t be completed because the original item for “Data” can’t be found”

Hello @etr385 ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing this issue in the latest build of Roon? Can you please provide some more details on your network setup, what is the model/manufacturer of your networking gear?

A good test here would be to see if you can add a Mac network share that has a few music files to the Nucleus, this way we can verify if both directions are inoperational or if it’s just to the Nucleus Data share:

Hi Noris,

Thanks so much for getting back to me. I haven’t tried setting up a file share to my Mac but will work on that in the next few days.

As for networking, I’m using a Comcast 3rd Gen Xfi Gateway (Model CGM4331COM). The Nucleus is hard wired directly to the gateway and the laptop is on WiFi. I’ve found that hardwiring the laptop to the gateway doesn’t fix the problem. Is there a particular setting I’m missing?


Hi Noris,

Sorry for the delay. I just did a test run with a network share from my Mac laptop and it worked fine. Still getting the error messages when trying to access the Nucleus from the laptop. Any idea what’s going on here?


Hi @etr385 ,

Thank you for confirming that the Mac Data share is working as expected.

Can you please share a screenshot or a small video clip of this error message?

Just to confirm here, if you try to access the Nucleus via the Network side-bar, does this also fail?

  1. Go to Finder
  2. In the side tab there is “Locations“ section
  3. Click on “Network“
  4. Then click on ‘nucleus’ in the list of available network locations

Hi Norris,

I finally solved my issue, albeit indirectly. I was able to put my music library on an external HDD and then transferred it to Nucleus via Virtual Machine running Ubuntu. I I think the real issue here is that my old MacOS was having trouble reading the newish Unix file system on the Nucleus. This may be why the Nucleus can pull from the Mac but not the other way around. To test the theory, I yanked the HDD out of the Nucleus and tried to directly mount it on the Mac via a USB/SATA adapter. With MacOS, I got the same permissions error as before, but with Virtual Machine / Ubuntu, I could get into the HDD no problem.

Case closed?

PS - I’ve been having a recurring issue with the Nucleus crashing when streaming Qobuz. I’ve posted about it in someone else’s thread a couple of times. This never happened to me until the last month or so, but is super annoying. Playback will randomly cut out in the middle of a track and Nucleus will restart. Only happens with Qobuz and recurrence is intermittent. Is your team aware of this issue?

Hello @etr385 ,

Thanks for letting us know that you were able to pinpoint the issue to the Mac permissions!

Yes, we are aware of a few similar reports and looking into this behavior, there is an investigation in progress. Thanks in advance for your patience regarding this.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.