Can't access Roon Core on Sonictransporter


(Stephen Graham) #1

So last week I got a sonictransporter to replace a Microsoft Surface Pro that I’ve been using to run the core successfully for a year or so. The only reason for the change was that I wanted to free up the Surface for other needs. The transition has been a bit sketchy. The first one was defective and had to be returned. The next one worked right away and I restored a core backup and was functional. That lasted for about three days or so and then Roon couldn’t find the core. The ST is still visible on the network and I could successfully ping it and access it through Mysonicorbiter (although response was very slow and it often times out). I tried changing cables, rebooting, hooking it up to the router instead of the switch. No joy.

Because the ST was visible on the network I decided the Roon installation on the ST might be the issue so I deleted it and reinstalled it. That seemed to be successful but I still can’t access the core through Roon. So I’m basically stuck now and back to using my Surface as the core. It’s working fine but I bought the ST to be used. I’ve already contacted @agillis but given that it’s the weekend I will have to wait a bit. So I thought I would try contacting the community. I’ve been reading through a lot of other posts and it seems that a number of other people have had similar issues but I haven’t come across any definitive solutions. Can anybody recommend any next steps to try? Any help would be appreciated.

My setup is as follows:

ASUS Router (RT-N66U) -> D-Link DGS-1210-20 (Managed Switch)
Everything else is connected to the switch by Ethernet other than an iPad that I use as a Roon remote
Music stored on Synology DS1511 NAS (fairly large library - approx. 130,000 tracks)
I have three endpoints (1 Auralic Aries and 2 Microrendus)


(Oliver P) #2

Hi Stephen,
I’m no network guru and never will be, but probably I’m able to narrow the root cause a little bit.

  • First idea: What happens, when you connect your ST directly to the router?
    -> if Roon works, there could be a problem with the settings in your switch, then go to idea number 2
    -> If Roon doesn’t work,… Well, no clue then.

  • Second idea: I’ve read some threads regarding managed switches and flow control (look here, for example), probably there is a faulty setting in the switch.

Good luck :sunglasses:


(Stephen Graham) #3

@Oliver_Pix Yes, I did try that but it doesn’t solve the problem. I can see the ST on the network but Roon can’t find the core. In the past I’ve had problems with my managed switches and the use of flow control between the endpoint and the switch but I’ve never had a problem between the core and the switch. Nevertheless, you have to try everything. Unfortunately, it didn’t help in this case.