Can't add album to library

Core Machine

Roon ROCK on your recommend Intel NUC.

Network Details

No Network Issues - Wired Ethernet

Audio Devices

LAN connection thru miniDSP SHD Processor. Operating Roon software thru my laptop as I always have… no changes with anything. Great throughput.


Description of Issue

Trying to add album to library and it just spins and will not add. It shows as one of the available qobuz versions, and I can play songs from the album just fine.

I attempted to add another album from qobuz and it added fine, but this album continues to spin.

I have restarted Roon and tried again… same spinning without being able to add it.


What region are you in? For reference, I’m in the Netherlands, and I’ve just added this album to my library from Qobuz without seeing this issue.

USA… I’ll try again a bit later.

Odd that I can add some of the songs to my playlist, and it remembers it, and I can add other albums, but that one just spins.


Hi @Sonnie_Parker

Are you able to add this to your library in the Qobuz app directly?

If “Favorites” on qobuz is the same as “Library” on Roon… then yes, it is listed as a Favorite. I don’t see any Library on qobuz.

Here is what I see…



Adding to that… every album I have added to my Library in Roon is in my qobuz Favorites, yet this particular album does not show up in my Roon Library.

Perhaps if I delete it from the qobuz Favorites, then try to add it… I’ll try that later when I get back home.


Hi @Sonnie_Parker1

Yes, apologies for any confusion, by library I meant favorites in Qobuz. This album added okay for me — Can you try removing it completely from Qobuz and then re-add in Roon? Let me know if there’s any change.

We have ghosts in the house… opened Roon up and low-in-behold… the album is in the Library. lol

Problem solved itself I suppose.


1 Like