Can't add NAS folder after updating to Catalina iOS on Mac mini

Core Machine (Operating system/System info/Roon build number)

Mac mini ~ 2016

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

tried wifi and ethernet. Centurylink Technicolor C2000T modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

can’t use them because I can’t load library

Description Of Issue

Received a Mac mini from a friend. was on Mojave OS. installed Roon software, got it to mate up with NAS–Synology ds 1515 I think is the model. It read contents fine. Saw Apple had new iOS, so I just updated – to Catalina. Since then, I cannot get it to accept the NAS folder under Storage. “There was an unexpected error: Unexpectederror.”
I erased all contents of the Mini and started new. same result.

There are a couple of things: firewall may need to be off, Roon requires access to disks, the NAS mount has probably changed, etc, but as you have erased everything, fault finding is meaningless. So I would start again following the installation guide. See also: configure my NAS for Roon and I’m having trouble setting up my NAS.

Hi @Matthew_Neal,

Welcome to the forum! I’d check the MacOS firewall by using these instructions and make sure that Roon and RAATServer have been added as exceptions.

Are you still able to access the NAS share by using Mac’s Connect to Server Feature (Method 2)?

Thank You. I did add the firewall exceptions.

It turned out to be a face palm moment. I had navigated a bunch of issues related to someone else gifting me their old Mac mini, and in the process I had an ethernet connected but no wifi and the particular ethernet was not the one which will be carrying my NAS stream when it’s hooked up to the hifi.

Appreciate the help. It’s running.

However, it’s interesting I was able to get a different service connected to the NAS via this same method. The cable comes from the isp modem/router where the NAS is plugged in via a separate cable. Shouldn’t the router share all connections? I don’t pretend to know the answer to that. But adding wifi was the difference in adding the Roon software.

Hi @Matthew_Neal,

Glad to hear you managed to resolve the issue!

I wonder if perhaps the Ethernet cable goes to a managed switch or was connecting to a different subnet than the one that the NAS was on. If the router has VLANs set up, this is a possibility. In either case though, glad to hear you sorted the issue out.

That sounds logical. I am surprised the same cable did transmit the NAS info to a different software service.

Bottom line, yes, really glad it’s running. I was so impressed with the Roon software. It reminds me of having my library connected to how was several years ago, but enhanced, and with streaming as well. It’s exciting. Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.