Can't add Qobuz album to library

Server on i5 Windows 10 16gb, ssd

Endpoint on i3 Windows 10 8gb, ssd

Wired 1gb ethernet, 200mbs internet, google dns

When I click + to add a Qobuz album to the library, it says added but the plus changes to a spinning circle that keeps spinning for minutes and the album never appears in the library. The album does appear in qobuz app favorites. Only noticed this starting to happen this morning.

Stupid question…

Do you by chance already have the album in your library?

I have had this happen a few times when looking at albums via Roon suggestions and I think yes I will try that and go to add it and get exactly what you state.

Really Roon should be showing it already in my library but it seems it does not every time, a bug perhaps?

After a couple of times of this happening, I have then searched my library and sure as sugar the album in question was indeed already there.

This only seems to occur if I am looking at Roon suggestions that appear under the album I am looking at/ playing at the time.

This randomly happens to me as well.

1 Like

Checked that. The album isn’t already there. Sounds like a different issue.

1 Like

I’ve had this a few times. I think I solved it by:

  1. Deleting the album from My Favourites in the Qobuz desktop app.
  2. Closing Roon Server and restarting.
  3. Checking that the problem album is now removed from Roon Library (if not, then try a forced Qobuz resync)
  4. Adding the album again, but this time on the Qobuz app.
  5. Forcing a Qobuz resync again.

After a few seconds (sometimes up to 30 seconds) the album then appears in my Roon Library.

Thanks. That gave me an idea. I went to services and logged out, disabled the service, re-enabled it and logged back in. After syncing, the albums were there.

One thing I noticed in services was that roon had my previous email address for my qobuz login. When I logged back in, I used my new email address that I had updated in qobuz app (but not roon, apparently). Maybe that was it.

Curiously, my old email address worked fine for months for playing from qobuz. Maybe some kind of auth token thing.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.