Can't add Roon Radio Stations

I add several .pls radio stations from

Roon accepts this one, but crashes when I start play:

this also the same

28 Feb 2018: both links work now, thanks

Hello @ger_tielemans,

Thanks for the report. We are investigating a few radio stations that cause Roon to crash and I have added the links you mentioned to the investigation. This behavior will be addressed in the next Roon update.

– Noris

@noris Can you please add this station to the bug list?

@Benjamin_Gold - Thanks for the report, added.

– Noris

Hi, there are couples of internet radios will crash the Roon server while it continues to play in the background. I no longer able to connect to ROCK using iPad Roon remote. I’ve to restart the Roon server in order to regain access to Roon. Here are a couples of internet radio links that will immediately crash the Roon server. - DI Radio Digital Impulse - Christmas Channel - Power 95.1 FM

The links above worked without any issue in JRiver, so I assumed there’s a bug here. Also those links that work without crashing, when switching to another station can randomly cause an unexpected crash. Hope you guys can look into it.

The devs are already investigating this. Meanwhile I"m merging into another list to keep them together.

The Linn Radio stations also make it crash.

thanks George! Noted.

And now Roon doesn’t accept any radio station anymore… roon1.6 build 401

Hello @ger_tielemans,

We resolved the issue with Roon crashing due to specific radio stations that contain special characters in our Roon b401 release.

I have just tried adding both of the streams you mentioned in your first post and they are working as expected for me:

Are you having issues adding these stations or what specific stations are you having this issue with? Can you provide some links to them? What is your Core platform (Windows/OSX/ROCK)?


I installed my Roon again on a nuc and had to reinstall all internet radios… but now all stations are refused, including the ones that worked before. Can be another problem?

By the way, I love my rock Roon, test now tidal and Qobuz

Hello @ger_tielemans,

If you reinstalled ROCK on your NUC, it is possible that you missed the step of adding the FFMPEG Codec to it, which is required to decode specific types of streams. Please review this page and let me know if this is the issue here:


I use rock on a nuc 6i5syh and iPad as control.and bluesound as output device. I updated the bios and installed ffmpeg with help of the good step by step instruction. I only went crazy when I did not bind nuc and musiclibrary device to ip: After power switch off rock could not find library (by the way, first link is ok but second link to John van sickle is broken)

Checks in browser front end for rock are ok. Everything works fine, with exception of internet radio ( I also do not like the big tiles without pictures for the radios: smaller tiles please)

I add radio urls in iPad control, could that be the problem? Will try windows7 control now…

No… same problem, for example

Hello @ger_tielemans,

Thanks for letting me know that info. Hmm, that link you posted worked just fine for me, I am wondering if your ROCK could maybe not have any internet access at all? Do you have TIDAL or Qobuz and can stream tracks from your Core? Can you try rebooting your ROCK using the following steps?

  • Open the ROCK Web UI
  • Locate the red button on the upper right
  • Click it once -> Press Reboot
  • Wait for the ROCK to reboot
  • On the WebUI press Roon Server Software -> Restart
  • Try adding the internet radio station again


Thanks Norris, these steps solved my problem. (Strange enough tidal and Qobuz did work)

1 Like

Hello @ger_tielemans,

Glad to hear that the steps worked for you! Thanks again for contacting support and hope you have a great listening experience! :headphones:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.