Can't add the network shared location

Using Win10 and my music is at my WDMycloud network HD.
The address is: WDMycloud\Music. When I type it in the Network share location box it gives me the “invailed network path specified” error.

What am I doing wrong?

Hi @tomer_solomon ----- Thank you for the report and my apologies for the troubles here.

Our knowledge base has good information on the best methods for mounting a NAS in Roon. May I kindly ask you to please give the article a read and let me know what else you’ve tried thus far.

Looking forward to your feedback!

Still can’t fix it.
My cloud HD IP address is
I Went to “add network share”, I typed: sub://
Got “invalid network path specified”


try “smb” instead of “sub”

I assume sub was an auto spelling correction? Are there any passwords for the my cloud, if so try entering them even if you think they may not be required.


Sub was a spelling autocorrect, I did type smb…
Also used the username and password.
Still the same error

Hi @tomer_solomon ---- Thank you for giving the article a read for me and sharing the results of your testing.

Moving forward, can you verify for me if you are able to successfully ping the WDMycloud from your Windows device? Procedure listed below:

  1. Tap or click the Start button, followed by All apps.

  2. Find the Windows System folder from the list of apps and tap or click it.

  3. Under the Windows System folder, click or tap Command Prompt.

Once opened, please type the following command and hit “enter” to run:

ping -t


2 quick suggestions

  1. Have you tried \ \\Music? (removing the spaces)
  2. In the WD online information, it suggests that everything is under a “public” share so try smb:// or \ \\public\Music (removing the spaces).
1 Like

It works!
/Public was the missing chain as Rugby suggested.
Rugby - you are the man,
thank you all for the assistance!

1 Like

Your Welcome! Enjoy the Music!

1 Like

A post was split to a new topic: Tracks Skip During Playback