Can't change album tag


(R. Neal) #1

Have a ‘soundtrack’ compilation album. I’m trying to edit a few tracks from the album to show the track’s original album by the individual artist.

I changed the file tags and album art on two of the tracks outside of roon. I then rescanned the tracks. The roon ‘album’ changed for one of the tracks but not the other. The album art changed for both tracks. I rescanned the album, same thing. Rescanned the library no change.

I deleted the track that would not change, rescanned the library, added the track back, rescanned again. No change. The track still has the soundtrack/compilation album name, not the updated name, even though the soundtrack/compilation name does not appear anywhere in the file’s metadata that I can see and it shows the updated album art.

I tried again, deleting the entire album, rescanned library, added it back, rescanned again. The problem track did not change.

Have checked all the import settings, tag preferences, etc. It appears to all be working correctly except for this one track. I played around with group functions but couldn’t seem to do what I wanted.

I’ve become quite obsessed, as you can see. Mainly I thought I understood how all this works but apparently I don’t. All this took about 10 seconds in JRiver without any drama.

Any suggestions?


(Miguel Rode) #2

I’ve been through several permutations of this “stubbornness” of Roon to refresh its database from updated file tags, particularly with the Work/Part tags. The one step I take that you don’t mention above is “cleaning up” the library after I temporarily remove the files from Roon’s scanning path. That helps sometimes (not consistently). While files aren’t available to Roon, go to Settings/Library and click “Clean Up Library”. Then make the files available to Roon again and cross your fingers :slight_smile:


(R. Neal) #3

Thanks, I’ll give that a try.


(R. Neal) #4

@Miguel_Rode, that worked. Thanks!