Can't "commit changes" in RoPieee network config screen

I’m using 2.464 stable of RoPieee. I use a static IP address and I want to change the netmask. However, when I change the netmask on the “Network” screen and press “Commit Changes” nothing happens. In fact when I try to change anything on the network screen (IP address, Static/DHCP), nothing happens.

Is this a bug with the web interface? A question for @spockfish no doubt.

As a quick fix, how can I make the changes at the OS level? I tried changing it in /etc/ropieee.conf but that doesn’t seem to persist across reboots so I guess there’s somewhere else I need to chanage it.

Can you send me feedback? After you made an attempt to change it?

Sure - feedback sent 0031b7bd99213ede

(both my RoPieee devices are behaving like this but I’ve only sent feedback from one)

Nothing special to be seen, except that I think you’re using IE.
And that’s not a browser that I test, so this might be a browser thing.

But just to be sure: what do you mean with “nothing happens”?

Do you get the summary window that shows you the changes made?


I’ve tried it in multiple browsers - IE, Firefox, Edge and Chrome.

In IE, I get the summary page showing the changes I have made but when I click “Save Changes” nothing happens.

In Chrome, Firefox and IE I don’t even get the summary window - literally nothing happens when I press “Commit Changes”.

Can I make the change in the OS anywhere?


I would suggest using DHCP and assign address reservations in the router for the devices you want to have with fixed addresses - a much safer practice. Is there a specific use case that needs a fixed setup in the Pi?

Fixed IP addressing is much more reliable than DHCP reservations if you have a proper managed network. I’ve heard it suggested before that DHCP reservations are “better” somehow and that simply isn’t true.

Anyway that’s not the point here. I can’t select and commit anything in the web interface. I can’t even change it to DHCP if I wanted to.

What I don’t want to do right now is reflash my RoPieee which would likely fix this, so until I get a chance to rebuild I would like to change the config somewhere in the OS.

What you can try is edit the settings in


and run



You need to reboot after doing this.

Yes that’s worked - I’d found the ropieee.conf file but didn’t know to run configure afterwards - thanks.

Whilst the netmask has definitely changed, the web interface doesn’t reflect the new netmask - don’t know if that’s the expected behaviour.

I remembered that I also had another problem with these two devices recently - the web interface didn’t pick up the last automatic update, so I had to use pacman to do it manually.

I’ll reflash them eventually - sure that will fix.

Thanks for your help.


1 Like

Speaking as a networking specialist there are times when fixed IPs are appropriate of course but I don’t think this (RPi) is the place for them in a home network. For a server or a nas sure, for a managed switch or network node yes. For some types of workstations yes and no. For a device like. RPi address reservation is perfect. Unless you need Specific DNS entries perhaps. Most people won’t even know what dhcp is let alone address reservation but you are free to run your network as you choose too.


Sure yeah, for the novice that’s true. But like you, I’m a network professional and have a big home rig where fixed IPs are by far the best option.

Having the option to do both is fine of course, but I wouldn’t say DHCP reservations are “safer”.

@Jamie_Tudor One of the issues of setting fixed IP addresses in devices - especially ones that get removed from a network for some reason and then get added back just happened to me. I had an IP camera that was set inside its internal web GUI settings as a fixed IP but was removed from the network before I upgraded to new infrastructure… so its was still in the right subnet but now conflicting with a newer DHCP reservation with the same address…took me a while to figure out what was going on - but if there was ever a good reason to keep devices as DHCP and use reservations that would be one of them :slight_smile:

True, that would be more convenient that’s for sure. Getting your camera out of that situation is hardly an enormous effort though is it, and how often do you change your IP range…

Having said that I did actually recently change my IP range recently for the first time in 10 years, to alter the subnet, and having fixed IPs meant I had to spend a morning going round changing them all. It’s definitely more work to manage a network like this, but then orderliness and tidiness is often more work with anything.

Very much horses for courses how you do this - I genuinely don’t think one option is inherently better than the other.