Can't configure ARC

Roon Core Machine

Dell Inspiron 3250 / Win 10 / 4 GB RAM / i3-6100CPU@3.7GHz

Networking Gear & Setup Details

new Spectrum router has no model info
Core on Ethernet; endpoints on WiFi

Connected Audio Devices

various - Marantz N6006

Number of Tracks in Library

Description of Issue

can’t configure ARC -
UPnP is confirmed ON
I’ve tried disabling Windows defender - no help
I’ve tried disabling IPv6 - no help

@Art_Lustgarten, welcome to the community and sorry to hear about your issues getting ARC configured. Can you copy the error message shown in your Roon Settings → Roon ARC tab? This message can help the community and Roon staff to diagnose what you are experiencing.

I also moved your post to the Port Forwarding support category which may be seen by others.

Here’s the error message …

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}

Also … this message is generated AFTER the ‘My Spectrum’ app allowed me to (1) reserve the IP address for my Core; (2) open a port designated both internal and external port 55000 and (3) protocol changed to TCP

Thank you @Art_Lustgarten. The diagnostics you’ve provided suggest that your Core is having difficulty reaching Roon’s servers. There are several independent factors that can cause this error, so Roon recommends double-checking the following to initiate troubleshooting:

  • Is your router firmware up to date?
  • Do you have any VPNs, proxy servers, or enterprise-grade security on this network?
  • Are you experiencing any issues with Roon Remotes, or other apps on your local network?

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Modem is Spectrum DOCSIS 3.1 model ET2251
Router is Spectrum SAX1V1K

Any further suggestions to solve my problem?

Hi @Art_Lustgarten,

I would suggest that you try to create a manual port forwarding on the Spectrum SAX1V1K router.

First write down you core ip-address and port number. You can find these in the Roon App under Settings → Roon Arc.

Take a look at this page. It’s a how to create a port forwarding on a spectrum router with screenshots.

Hope it helps.

Kind regards,


1 Like

Hey @Art_Lustgarten,

Thanks for your patience while we work through every thread! Following up here, are you still running into issues getting Arc set up?

Have you gone through @Maarten_Duits’s suggestion on the most recent reply?

I’ll be monitoring this thread for your reply :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.