Can't connect my Mac to my Nucleus

Core Machine (Operating system/System info/Roon build number)
Nucleus, see video for information.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Wifi with an Orbi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I can’t connect my new Mac to my Nucleus core. I could with my old mac, but don’t know how to do the new Mac.

Here’s a link to a video I made showing the issue:

Hi Josh,

It looks like you’re not including your user name and password for the Mac 2019.

Here’s a link to setting a share with your Mac.

As for the missing Playlists, is your Nucleus new and are the Playlists missing since you switched your Core from the old MacBook?

If the Nucleus is new, did you do a restore from your old Core? If not, you would not have access to your playlists, play counts and all other data.

Let us know. If you didn’t restore, that would need to be done before adding the new share.

Cheers, Greg

I did not restore from the old core when I set up the Nucleus the first time. I don’t have the old core files I don’t think. Would it make sense for me to delete and start over again? If so, how would I go about doing that?

If the Nucleus is your first and only Roon Core, you’re fine. If you had your Roon Core on the old MacBook, then you needed to create a backup from it and restore it to the Nucleus. That would be how you get your old Playlists back.

If you don’t have a backup from your old Core and don’t have access to the old Core, you may be out of luck retrieving your playlists, play counts, etc.

Please confirm whether you have access to your old Core.

Cheers, Greg

I don’t have access to my old core. I want to know how I would go about starting over again. There must be a way for me to delete all the old information and start over as if this was my first setup. The Nucleus has a hard drive in it and it should be able to erased and start over again, or one would think. Thanks in advance for your help.

It appears I have four folders with Roon backups from April 2019. Could this be the type of backup file I’ll need to restore? That would be about the time that I bought the Nucleus so I would that that backup is my old core.

Hi Josh,

Ok, if you’ve had the Nucleus since 2019, I’m not sure you need to restore a backup.

Let’s concentrate on the getting the storage location share working. You need to add a username and password to get it connected. Follow the instructions below.

Cheers, Greg

I still can’t get a shared volume. See my video to see what I’m doing. I’ve followed your instructions and nothing is happening.

I’ll tag @support for you (I’m not Support, just a user like yourself). I’m not sure when they will be along to help. There may be a delay due to the holidays.

In the meantime, could you post some screenshots? It’s difficult to read what you’re typing on the videos.

Cheers, Greg

Here are the three screen shots that you wanted to see, or I think you want to see.

@support Greg,

I appreciate your help and support if you see this, I’m not impressed. It’s great you have volunteers helping, but it’s not better than having telephone support. You guys said it was better and in my opinion it’s not even close. I’ve now spent over five hours on this problem because you don’t offer live support. My guess it’s going to take at least that long to solve this problem playing online support only tag.

There needs (IMHO) to be a method to escalate to solve problems so you don’t have an ever increasing level of frustration with your customers, that is if you care about your customers.

Josh Patrick

Thanks Josh,

Try (use / not \):

smb://MacbookPro2019.local/iTunes

Username use:

Josh Patrick

Then add your password.

Cheers, Greg

Also, if you haven’t tried it yet, you should click the 3 dots icon to the right of the old Storage location and Edit it with the new information.

Cheers, Greg

There doesn’t appear to be a place to edit the hold storage location. When I hit browse I get a nucleus setting with no place to change locations.

Here’s a video of what I’m doing.

Hi Josh,

You’re on the right track. You Browse and then click Add Network Share at the bottom left of the window.

Cheers, Greg

I’ve done that and the error message that I’ve sent you several times keeps coming up. Is the username and password the same that I use for my computer or is it something that I need to have that came from Roon or Nucleus.

Hi Josh,

Sorry you’re still having issues. Yes, it would be the username and password you use to log into your computer and the one that might be asked for when you install software or make changes to setting on your Mac.

What macOS version are you running? I tested adding iTunes to my Roon using Big Sur and I was successful.

When I suggested you use the username Josh Patrick, it was because of the screenshot you provided showing the Share for your iTunes folder.

Also, if you click Options, like you did in the video, it should show Josh Patrick with a check mark beside your name. When you click the check mark on or off, it should require you to enter your password to make the change. That’s your computer password. You could try it again to make sure the password you’re using is correct.

One last suggestion, in the instructions I linked, macOS Catalina (maybe Big Sur?) had a bug that sometimes required users to click the check mark next to File Sharing off and then on again. See here:

Please Note: On early releases of macOS Catalina, you may receive an error when adding the Network Share. One thing to try is to click the File Sharing checkmark Off, then On again in System Preferences > Sharing.

Give the above a try and try creating the share again. If you still get a error, please post a screenshot.

Cheers, Greg

Hi @Josh_Patrick,

Greg is definitely on the right track here (thanks, Greg!) — One other thing I’d like to check is whether or not your password has any special characters in it. If the password for your Mac is not alphanumeric can you try changing it so that it is and let us know if that helps?

Another good troubleshooting step here — Do you have another machine on the same network you can use to try to access the smb://MacbookPro2019.local/iTunes path? Are you able to access it from another device that isn’t the Nucleus?

I finally got the share to show up by getting rid of one of my shared folders and added Administrators for read and write.

Now, I don’t have my playlists which was the whole purpose of this exercise. I’ve made a video to show you what I’m talking about.

Here’s the video - https://www.loom.com/share/2c351bfe701648ca8aff666689e0f945

Hi @Josh_Patrick,

If you click the 3 dots next to the folder in Settings > Storage can you confirm that Import iTunes Playlists is enabled?

Assuming it is, head over to one of the tracks that should be in a playlist in Roon and click the 3 dots and choose View File Info. Share a screenshot of that here. Thanks!