Can't connect Nucleus+ to Tidal

Hi there,

I’m on my 14-day free trial of Roon. I’m using it at the moment to play Tidal through a Linn digital streamer. When I was using my desktop Mac as the Core everything worked fine, but now I’m trying a Nucleus+ I get told when trying to set it up that my Tidal username or password is no good. I’ve tried:

  • Changing my password in the Tidal app
  • Checking I still have a Tidal subscription (I do)
  • Power cycling the Nucleus+ (this allowed the password to work once but then I made the mistake of pressing ‘back’ and it didn’t work again after that!)
  • Deleting my Tidal cache from the library

Any help would be appreciated - thank you!

Thanks for reaching out, @Josh_Raymond!

Can you confirm what version of RoonServer the Nucleus+ is on? If it’s not on the latest version of Roon (Version 1.5 Build 334) you may need to update. You can check this by using the Nucleus Web Administration Interface or by going to Settings > About in Roon.


Hi Dylan,

Thanks for the quick reply. I sorted the problem, somehow, via a frenzy of uninstalling, reinstalling and restarting everything. Tidal now working well. Is there a way to have the Roon Nucleus recognise the music on the hard drive of my Mac, or does it need to be on an external NAS drive?

I am running the latest software.

Best wishes,


Hey @Josh_Raymond,

I’m glad you were able to get that resolved!

Yes, you should be able to use the music stored on the Mac. In Settings > Storage you’ll just need to add the music folder from your Mac as a networked watched folder. To do this you’ll want to make sure that the folder in question is properly shared.


Hmm. I’ve made iTunes Music a shared folder but it still doesn’t come up when I hit ‘Add Folder’ in settings > storage. Any ideas? If I try to drag and drop it into Roon it says that no storage location is available. I’ve tried restarting the computer…


Hey @Josh_Raymond,

From the Choose Music Storage Folder screen you’ll need to click Add Network Share in the bottom-left. This will allow you to enter the network share location, username, password, and workgroup for the shared folder you set up. Once you enter all of the information here Roon should be able to watch this folder.

Let me know if you have any issues adding this here.


Hi Dylan,
No joy I’m afraid. I copied in the folder location
but got a message saying ‘Unexpected Error’
Any ideas?

Hey @Josh_Raymond,

Since this is a networked folder, things are a little different than adding a local folder.

I recommend checking out this article about setting up a network share folder.

The share you need to enter would look something like this:

\\ShareComputer\Music (for example)
smb://ShareComputer/Music (for example)

This would be the same path as if you were accessing the shared folder from a PC or Mac.

I hope this helps!


That article seems to be about NAS drives? I’m just trying to share the music in my music folder on my Mac.

I tried copying in both of the things you suggested but it said Could not connect to share: host not found.

Hey @Josh_Raymond,

Yes, that article is about NAS drives, but the same information applies to any shared drives.

The items I pasted above were examples, but would not exactly as is for you.

First, what is the name of the computer you are sharing from? Alternatively, you can use the IP address. This will go into the DNSName or IP Address section below.

Next, what is the name of the folder you shared? This will go into the Folder Name section below.


\[DNSName or IP Address][Folder Name]
smb://[DNSName or IP Address]/[Folder Name]

You’ll also want to make sure you are including the username and password fields.


I managed to get my NAS recognised so all good. Have the music on there now and enjoying the Roon interface a lot, though I may experiment with an SSD in the Nucleus as sound quality doesn’t seem to be quite so good from the NAS as through Tidal. Thanks for your assistance.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.