Can't connect to 5GHz WiFi, RoPieee ver. 219


Setting up my first (EDIT: RPi 3 B+) RoPieee. Imaged the SD card, connected to LAN, powered up, waited until the green light blinks slowly. In the web interface I selected the country/time zone, changed the hostname, committed changes, rebooted. In the network tab selected “Enable WiFI”, committed changes.

If I don’t reboot now I can see my 5GHz network among my separate and other 2.4GHz networks. So, I select it, paste the WPA-PSK passphrase, commit changes, reboot and disconnect LAN. The RoPieee is nowhere to be seen on my network. The access point logs indicate it never tried to associate. I plug in LAN, go to the web interface and see only 2.4GHz networks, no 5GHz. Refresh. The number of networks changes sometimes because some are far away near the noise level, but my 5GHz SSID never shows up again. Feedback 0887d10de791ae61, if it can be useful.

I re-imaged the SD card three times. Re-setup three times with the same results. The only time I can see my 5GHz network is after I enable WiFi and before reboot. Once I reboot it’s nowhere to be found. It’s like reboot disables the 5GHz band.

If I select my 2.4GHz SSID and enter the passphrase it connects just fine and everything seems to be OK. But I’d like it to be on the 5GHz network. Can you look into this please?

I am 2-3m away from the access point, so the signal is strong. I use WPA2 personal with AES/CCMP encryption only. The wireless network is solid an works fine with everything else 5GHz and 2.4GHz.

As a side note, in the information tab can you please list the Ethernet, WiFi (and Bluetooth just in case) MAC addresses? It could be very useful for me as I don’t assign IP’s to unknown MAC’s on my LAN. Many devices have have stickers with their MAC addresses but not RPi, so I had to hunt for them in my router logs.


Pi 3B only does 2.4 :wink:
no idea why, during setup, RoPieee also lists 5GHz networks: this is probably something that might be fixed

EDIT: sorry 3B+ also does 5GHz

Forgot to mention. I have an RPi 3 B+ that DOES 5GHz.

1 Like


I think I know why I don’t see my 5GHz network. I ran “iw list” and noticed that channels 144-165 and some other channels are disabled. My network is on channel 153.

Based on this chart:
the pattern of disabled channels corresponds to Japan. I selected Canada/Eastern as my timezone as I am in Canada. As far as I know the RPi 3B+ needs the country set up before it enables WiFi. I assume that selection of timezone does that.

I tried selecting USA/Eastern - the same 5GHz channels are disabled while 2.4GHz channels 12 and 13 are enabled while they should be disabled in the US and Canada.

I don’t see where to set the country for WiFi in RoPieee - wpa_supplicant.conf has nothing, ropieee.conf has no entry like this.

Please help me enable those channels. They are enabled before reboot, so it should be possible.

P.S. “iw reg set US” (or CA) fixes it but doesn’t survive a reboot.

(I’m ignoring the ‘please fix’ attitude. Hope this is a language thingy and I’m interpreting it wrong…)

Having said that, RoPieee sets the region for wifi not based on the timezone, but detects this automatically based on geo ip. So it should set it to US or CA unless the geo ip location does not return something valid.

I’ll check your logfiles to see what it says.


Is the feedback that you sent me only with wifi? Can you send me one with ethernet connected as well?

Sorry, I don’t understand what you meant by this. I didn’t mean anything bad, although I did ask to “fix it” like many others on this forum.

No, it was only with Ethernet connected as I couldn’t connect to WiFi. I think it was before I attempted to connect to the 2.4GHz band. I did 3 setups with newly imaged sd cards. If I remember it wrong here is a new feedback: d9ba052bb81d21aa. It’s with Ethernet connected, WiFi enabled but never connected. geolocaes me correctly.

@G_P can you login with SSH please? And run the following:


I got “nl”.
It is not my IP in the URL in that script.

So did I get “nl” and Im in Singapore… Houston we have a bug :D. All my ropieee’s say the same thing…maybe they are homesick :wink:


Ok guys, found the bug.

I’ll fix this asap, and release something this weekend (can’t promise it’s tonight).
So @G_P, I expect you can use 5G somewhere this weekend.

What you can do as ‘quick fix’ is making a simple change to that script. Replace the IP address with ‘check’ so that it looks as follows:

... ...

This means I need to change test procedures for RoPieee: it requires me going abroad with every release :wink:

Thank you, @spockfish. I hope you travel abroad by VPN :wink: At least for such purposes.

I was going to insert ‘check’ into that script as you suggested, and I decided to start anew. I re-imaged the sd card with exactly the same image (v219) that I stored on my hard drive. I proceeded with setup, enabled WiFi, rebooted and to my surprise saw my 5GHz network. I executed /opt/RoPieee/lib/get_country_code and got “ca” which is correct. I checked the script and it already had ‘check’ instead of some IP address. I was a bit puzzled but what I was going to do (insert ‘check’ in the script) was already done somehow. Maybe you did something on your side that resulted in this, I don’t know.

But my problem is unfortunately not over. I pasted my 5GHz WiFi password and I still can’t connect to my WiFi. Access point logs show no trace of connection attempts from my RoPieee. I rebooted it several times, booted with the Ethernet than unplugged the cable. Unplugged the cable then rebooted etc. Whatever I tried it never attempted to connect to my WiFi. Here is feedback ID if it can be helpful: a5e1726b991c02eb

I checked ‘iw list’ and the proper channels for Canada are enabled now including the one I am on, and I see my SSID in the network tab.

Can you please look into this? I don’t know if it’s a RoPieee problem or a Raspberry Pi one. Do you know anyone using RoPieee on a 5GHz WiFi? Anyone who reads this forum?

I just changed to the 2.4GHz WiFi and it connected right away (after reboot). That was after I created the feedback.

Hi @G_P,

The reason why it is already changed is because I used RoPieee’s ‘rescue system’ to solve this.

5G should work, because I’ve tested it after your report over here, and it works.

However, I see in the logs that it reports thta the key is not correct. Can you test with a simple key first?

@spockfish, thanks for the pointer regarding the key error. I think the problem is that my WPA passphrase has many non-alphanumeric characters, while my 2.4GHz passphrase that worked has only alphanumeric characters.

After some googling I found out that ArchLinux has problems with complex passphrases. Please have a look at the section “Password-related problems” here:
I get this failed 4-way WPA handshake, PSK may be wrong error while my passphrase is definitely correct as I paste it directly from the access point controller. Many devices have worked with this network for years.

I wonder if you could implement the suggestions from that article?

working on it…

1 Like

Release is out.

It’s working now with “strange” characters. Thank you, Harry!

I have to say I was quite surprised that Arch Linux didn’t follow the standard and needed a workaround, and non-alphanumeric characters are allowed in the PSK. Over the years I had only a couple of old Foscam cameras that didn’t like certain characters in the PSK. Everything else worked fine.

And I am a bit less surprised that I am the only one here who uses strong passwords for WiFi :wink:

It is perfectly possible to create a strong passkey with only alpha-numeric characters. I use a password generation tool for creating (and securely storing) strong passwords, and I deliberately configure it to use only alpha-numerics to avoid these kinds of issues. They occur frequently enough to make it simplest just to avoid them altogether.

of course sometimes you fall foul of the opposite issue, where passwords/keys MUST have at least one non-alphanumeric character. Jeez thats annoying! :wink: