Can't connect to Core on Synology NAS


I’m owning a Synology DS218+ NAS 6GB RAM and a SSD where my music library is stored (which is connected via USB 3.0).

I created a shared directory “RoonServer” wich is linked to the SSD and installed the RoonServer_Synology_x86_64_2018-03-07.spk on the SSD. And the Service ist running (Package centre)

Sadly, the core can’t be found when I try to connect via Roon App from Mac, iPhone or iPad.

Then I installed the core on my Mac. Now I can find the roon core on my mac from any device.

Do you have any idea what the problem my be? I’d really like to place the roon core on my NAS…

Thanks and best regards


Is this the same (external) SSD you keep your music on? You will need to share the External Device as RoonServer, per @crieke’s instructions:

If you’d like to use an external, usb connected SSD as a storage volume for RoonServer’s database, you’ll need to rename its name from something like usbshare-x to RoonServer (external volumes can not contain multiple shares and they are a shared as a whole)

If the above is all set: is the firewall on your Synology turned on?

Yes, I installed RoonServer on the same SSD I keep my music.



I turned the firewall on the NAS off, but it had no effect.

That should be fine.

Have you tried rebooting the NAS with firewall off?

Yes, I made a reboot with firewall off. But still the same: core not found.

Thanks for reaching out, @Jens_Muller.

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

If you use an app like Fing that scans your network on one of your remote devices, are you able to see the Core machine from the remotes?


Thanks, Dylan,

that was the right hint! My NAS ist directly connected to the router. But all other divices via my LinkSys Velo. I only had to change it into bridge mode. And now everything’s fine! :slight_smile:

Thanks a lot!



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.