Can't connect to core : trial version

Core Machine (Operating system/System info/Roon build number)
Mac OSX 10.14.6/Latest Roon version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi, I started yesterday the 14 days test.

I installed Roon, set the audio device, set the storage and everything worked fine. For now I’m using Roon on the same mac running the Core.

Next morning (without rebooting the Mac) I started Roon and it ask me either to set up a Core (again) or to find my Roon Core.
Clicking on the latter it looks for the Core indefinitely.

What I’m doing wrong?

Thanks in advance,

Hi @Paolo_Volante,

Are you controlling Roon directly from the Core machine or are you using a different remote device?

If you’re using Roon all on the Core machine, if you choose “This Mac” it should let you get started like normal since “This Mac” was already set up as your Core.

If you’re using a different remote device to connect to the Core, can you give us some details on your networking setup?


I use Roon directly on the Core machine. If I click on Use This Mac I’m prompted with a login or sign up window.

I login correctly and then I get an error message stating that I’ve already signed in on my mac machine… But no way to access the music.

the Trial will soon expire but I had no answers from you and since 6 days Roon is not working. It worked for only one day.

Hello @Paolo_Volante, my apologies for the delay over the holidays, but we’re happy to help! Do you see an option to unauthorize your “previous core” after you sign in? I know it’s the same mac, but reauthorizing won’t cause any loss of data. If you see an option to disconnect the previous core click it and try to sign in to your mac again.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.