Can't Connect to Music Folder on NAS


I am a new user, running Roon on an exaSound PlayPoint (latest versions for all software and the device itself). My music is stored on a Synology NAS. I received an “UnexpectedError” message when attempting to login into the music folder on that drive. My password did contain one special character, #. I changed the password to contain no special characters, but got the same error message. What should I do to get around this problem?

post a screenshot of roon settings, storage that might help

1 Like

Hi @Jeffrey_Hight,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you please also share the path that you are entering into Roon for the NAS?

My network is both wired and wireless, although my use of all music-related hardware is strictly wired. Routing is handled by an Apple Airport Extreme and three TP-Link gigabit ethernet switches. The Roon Core resides on an exaSound PlayPoint network audio player. The music library resides on a Synology DS718+ NAS device. I can access the library using my Mac Mini with no difficulty. However, when attempting to connect to the library through Roon, I receive an “Unexpected Error” message. The path I am using is smb://SynologyNAS/PlayPoint Music. My original password did contain a special character, but that has now been removed, without resolving the issue.

Thanks, @Jeffrey_Hight.

Using the smb://SynologyNAS/PlayPoint Music path, are you able to access this library over the network from a Windows or Mac machine?

What model switches are these? Can you confirm if they are managed switches? Is your Core machine and NAS connected to the same switch?

Yes, I can connect to the the library with my desktop Macintosh with no difficulty. The switches in question are two of the model TL-SG108E and one model TLSG108PE. The device running Roon Core was in another room on a different switch but, for testing purposes, I have moved into the same room with the NAS and they are both presently on the same switch.

The lone POE switch is managed; the other two are not.

All three switches operate just fine without any supervision on my part. Interestingly, when I replaced the library music storage location with my previously used portable USB hard disc drive and initiated library updating, not only was the library on the portable drive accessed by the Roon Core, but I could clearly hear disc activity on the NAS when there should have been none at all. When I shut down the NAS, I briefly saw a message referencing Roon and the NAS; unfortunately I wasn’t able to record the message. Odd behavior . . .

Hi @Jeffrey_Hight,

I’d like to propose a test that should give us some additional information here. Since you can access the library from the Mac without issue may I ask that you please try to temporarily use the Mac as your Core machine? When you do so are you able to add the NAS folder to Roon?

Yes, it works when using the Mac as the Roon Core.

Hi @Jeffrey_Hight,

Since things work okay with the Mac as a Core, it definitely sounds like there are some networking difficulties at play here preventing the PlayPoint Core from connecting to the NAS.

Is there any difference in how the Mac is connected to the network compared to the PlayPoint?

No, they are connected in the same way. What strikes me as odd is that, when I attempt to connect to the NAS through Roon Core, the NAS kicks into action and disc activity is heard. But, it still refuses to connect.

Thanks for the info, @Jeffrey_Hight.

Moving forward, I’d like to enable some diagnostics on your account so the technical team can take a closer look. Before doing so I was hoping you can try to connect the NAS in Roon once more. Once you’ve tried to connect and receive the error in Roon please make a note of the time.

Reply here with the timestamp (and your timezone) and I’ll enable diagnostics.

I made another attempt to connect the NAS as storage for the Roon Core at 7:40:15 am Eastern Standard Time.

I also saw the error message box again, and was able to take a screen shot of it this time. JHHSNP Files is one share folder on the NAS; there are two others, plus whatever it is that Roon is referencing (which is not anything I can see on the drive).


After reading a bit more about networking – specifically the use of the two ethernet ports on the Synology NAS – I activated a bond between the two ports on the device using its control panel. Although it didn’t connect using the path smb://SynologyNAS/PlayPoint Music, it did connect using the path \\PlayPoint Music ( being the ip address of the NAS). I hope this is a permanent fix for my issue but, knowing little about networking, I will be interested to hear of any thoughts on my situation.