Can't connect to music on NAS drive -- network share error 68 [fixed]

Without doing anything to my set up, except being gone on travel for a couple weeks, all the music on the NAS drive was suddenly not available and it said under the Storage tab in Settings, “Error connecting to network share: 68” I tried everything I could think of, including reading two prior posts which involved the same error message, but nothing has helped. I have the latest versions of everything and Roon is running on a new MacBook Pro. The NAS drive is a Synology 415+ I think. This is crazy complicated when something like this happens, and I am not a computer expert, just an audiophile.

Does anyone have any suggestions I could try? Thanks, and happy holidays!

While you were away, was the NAS or the network rebooted? Is the NAS on a dynamic or fixed ip address? It should be on a fixed address.

The only thing that could have happened is the power could have gone off briefly. I assume the NAS is on a fixed ip address, because it’s always been the same address.

Hi Kerry,
Can you double check to see if your NAS is still on that ‘same’ IP address?
If it has changed that would explain why Roon can’t see it anymore.

It also worth, making sure that it really does have a fixed IP [this applies to all servers really].

If the IP has changed, you will have to remove the current Roon watched folder and then re-add it with the new credentials.

Hi Carl,

What exactly is a “fixed” IP? Can you please explain how I can check to see what IP address the NAS is on? Thanks very much.

Thanks for the suggestions. I was able to reboot the NAS drive again and this time the problem went away. Thanks for the help.

Background Information - Why IPs change

Most networked devices get their IP address using DHCP. The way this works is when the device boots it requests from the DHCP server what IP address it should use.

The DHCP server (typically within your home network router) maintains a pool of IP addresses it can hand out to devices that request them.

In order that IP can be reused, each assigned IP has a lease time (let’s say 2 hours) if a device is switched off for more than this time … Then when the device is powered up again the DHCP server is free to allocate it any available IP … So as I hope you can see, this new IP could well be different to the original one allocated.

Options to prevent IPs changing

  1. In the router, go to the DHCP allocation table page and set the router to permanently reserve an IP address for a given device [MAC address]. Then when the device reboots it always gets the same address.


  1. Configure the device (your NAS) not to use DHCP, but instead to use a fixed IP address that you configure in that device. It is VERY important that this IP is in the same subnet range as your home network and that it will not clash with any other devices.

Personally I prefer option 1 and this is how my home system is setup.

I know this is quite technical, but alas computer audio esp. network based does require some knowledge of these topics. The manual for your router and NAS should have sections on this.

I use an iPad app called fing to scan my network for devices, I find it makes it a little easier to see what’s going on.

I hope this helps a little.

As per Carl’s suggestion, you should verify the current IP address and make sure the NAS is set as a fixed IP address.

Thanks to both of you, this is very helpful and I will try to run this down.


I am getting the same error report when trying to connect to my Synology DS212j NAS in order to use my Squeezebox Touch.

I have stopped LMS on the NAS and re-set my router to permanently reserve the IP address for the NAS. Still seeing the same error message.

Are there any other suggestions I can try?

Many thanks for any advice.

Hey @Philip_Kent – can you let me know a bit more about your setup, in particular the details of your Core, and how you’re trying to add the NAS, meaning are you browsing, adding it via IP address, using host name, etc.

Let me know and we’ll figure this out. Thanks!

Dear Mike,

Thank you for getting in touch, I will try to give you as much information as I can. I know enough about this to be dangerous but not quite enough to be competent!

I have Roon v1.2 installed on my Mac computer. Currently it is pointing to my music files stored in iTunes on the Mac’ hard drive. I have separate profiles for my Apple TV and my dragonfly DAC. The connection to the AppleTV is through Wi-Fi where as the DAC just plugs into the USB port at the back of the Mac and is automatically recognized.

So far so good!

My internet connection is via optical fibre through my modem into a TP Link Archer C7 wireless router. The Mac connects to this wirelessly.

My Squeezebox connects to my network through Ethernet using the switch built into the wireless router. My NAS connects to the network the same way. Before Roon was installed I had no difficulties controlling playback through my Squeezebox from music stored on my NAS accessed through the browser interface to Logitech Media Server (installed on the NAS) from my Mac.

The NAS is a Synology DS212j.

As mentioned on the forum the method I used to connect Roon to the Squeezebox was:

  1. Turned on Squeezebox support on Roon.
  2. Turned off Logitech Media Server on the NAS.
  3. Tried to get Roon to watch my music folder on the NAS. At this point I got the “error 68”. I tried the following approaches to get round this:
    Tried pointing to the network path with and without user name and password.
    Tried pointing to the path using IP address of the NAS.
    Tried creating a reserved IP address in the DHCP function in the router and pointing to the reserved IP address.

So far the error persists.

Any help would be gratefully received. If anything is unclear just let me know.

Thanks a lot.


Hey @Philip_Kent – thanks for the information, very helpful. I want to confirm exactly what you’re entering here:

Tried pointing to the network path with and without user name and password.

If this isn’t what you’re already doing here, I’d recommend using a login and password with your host name, like this:


Let me know if that’s what you’re already trying or if you’re having a different issue. You can also try opening Finder and entering this network path under Go > Connect To Server, which should confirm you’re entering the correct path to your NAS.

Hello Mike.

I’ve been trying the following:

smb://DiskStation/Music/iTunes Music NAS (being the path to my music) with and without my user name and password and the NAS admin username and password.

I have also tried

smb:// Music NAS being the IP address that was reserved for my NAS by the wireless router. Also with and without the username and password for my profile and the admin profile.

Your feedback about Go>Connect To Server seems to be on to something. When I tried to connect through this path it came up with an afp:// address which failed to connect. I believe that Roon does not work on afp so maybe there is a conflict? I have this connection because I have a separate partition on my NAS for my Time Machine backups.

Apologies if I am talking nonsense. I refer you to my first sentence in our correspondence!

Hey @Philip_Kent – it sounds like your QNAP may be defaulting to AFP, instead of SMB which Roon requires (and which should work better in most cases).

Before you make the change, are there other programs using your QNAP that might be depending on AFP? Time Machine backup, anything like that?

To set the QNAP to use SMB, you’ll want to configure it like this:

And to disable AFP, you’ll need to uncheck the box here:

Let me know how that goes. I think once Go > Connect To Server works, you should be all set.

Dear @Mike,

I’m pleased to say that your advice has worked perfectly and I am now enjoying all of the benefits of Roon and Tidal integration through my Squeezebox.The afp incompatibility is an important point for people using a NAS, particularly if they have Time Machine configured on the same system.

Just another observation, your screenshots above are actually for a Qnap Nas whereas I use Synology. Nevertheless, the user interface is very similar and I had no problem following the instructions anyway.

Thanks again for your help, Mike. I am very impressed with the service.

Great news @Philip_Kent!

I actually have a Diskstation here, and had someone on the team with a QNAP grab those for me… No idea why I thought you had a QNAP, but glad we got this working for you regardless! Thanks for letting us know!