Can't connect to NAS drive

late 2014 iMac (Retina 5k, 27-inch, 4 GHz Quad-Core i7, 32 GB DDR3, Mc OS 10.15.4_

Can’t get started because all of my music is on my

Synology NAS

and no path that I try to type in to the “Add Network Share” works. Everything I try gets “unauthorized” (even if I think I’m giving right username and password) or “unexpected error.”

You need to give the username/password that you use to logon to your NAS.

Unexpected error is probably a path problem.

Are you using the IP of your NAS?

I don’t use a NAS for Storage, but here’s how I specify my networked drives for Settings==>Backup -


Tried using the username and password I use to log onto the NAS, doesn’t like it. Says “not authorized” even though that username/password work from other apps.

Tried using the IP address as well, but it didn’t like the path.

Have you examined the Permissions list for the Shared Folder your music is on in the Synology?
In my Synology NAS Shared Folder there are a number of Local Users, Some have Read/Write permissions and some don’t. Also check that Advanced Permissions list the User as Read/Write.

Thanks. I actually have only been using the main “admin” account to connect to the NAs and therefore tried to use “admin” with its password. Was surprised that wouldn’t connect, as “admin” has full permissions.

Hello @Max_Paley and welcome to the community! We have instructions for adding a network share available here. Are you able to connect to the NAS outside of Roon still? If not, I would agree with grossmsj about checking the permissions.

Also, can you share he full path you’re using so we can take a look to see if anything about it stands out?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.