Can't connect to Roon after changing router to Asus RT AX88U

I recently upgraded my router to the RT AX-88U and after doing so, Roon could not connect to my Roon Nucleus+ core. It did not have any issue doing so on my previous router. This issue has also meant that my Sonos speakers were no longer detectible when i fired up Spotify. Asus were completely useless in helping me troubleshoot - kept asking me to just try reset. Wondered if others have experienced this issue and can help me figure out how to resolve?

Have you rebooted/power cycled your Nucleus core? It may need a new IP address lease.

I have power cycled my Nucleus core but the same problem persists. My nucleus core is actually detected on my other network and so if i am on that network, i can connect to the nucleus core but not on the network created with the new router.
Hence i think it might be the new router but Asus could not tell me how to resolve.

“Other network”?? There is your problem: 2 networks, 2 subnets. Choose one :wink:

Thanks Mike, i have two networks because they cover different floors in the house. Choosing one means streaming becomes nigh impossible. I didn’t experience this issue when using the old router before the upgrade. That is what puzzled me. If this was because of two subnets etc, then i would have had the problem even before i upgraded.

If you didn’t have the problem before you upgraded then this indicates indeed that there were no two networks. Maybe there was just one accessed via two access points with differing WiFi SSIDs?

Any advice as to how i would verify that and then reinstate on the new router?
Thank you

Take the previously working device that you just replaced, connect it to your wired network, provide it with power, turn it on and check its configuration (preferably from a wired PC/Mac/device).

Hi @Melvin_Sng,

Roon requires every device to be on the same network and subnet. It’s likely that the previous setup was done in a way that allowed the second network to act as a bridge rather than a completely separate network.

Can you elaborate a bit on your network setup? What are all of the devices in use? Which device was the one that was the replacement? Understanding this might help us get you in the right direction here.

Dylan, thanks. I had set up the previous router with as another network. it is possible that it was linked to the primary one as Jaguar suggest but i need to check. I use separate routers on each floor on of my house - all of which are defaulted to be wireless network routers. Apart from the primary router, the others are all the same make Asus RT AX88U. The one that i swapped out was an older router by Asus - an IPv4 - an RT AC68U. When i was using that old router (AC68U) i didn’t have an issue connecting to Roon core with that set up.

Hi @Melvin_Sng,

I would suggest checking to see if there are “Bridge Mode” options for these routers. Essentially you want one router acting as your primary networking device and all other routers to be acting as access points for that router. This will make sure that everything is connected to the same network and on the same subnet.

You can use Ai Mesh on supported ASUS routers:

1 Like

Has anyone resolved that problem with Asus AX88U router? I switched from AC86U to AX88U and my core is missing like with some others with same router. All my network configuration and firmware are exactly same. As a base configuration. Both are Wireless routers with 2.4 and 5GHz SSIDs and IGMP Snooping enabled. About 20-25 devices in my home network all working fine. Both wireless and wired. But Roon Core isn’t available in network.

There must be a feature in AX88U that is doing this. But as I’m not a professional, some of those are too hard to solve. Swithed back to AC86U, and everything works fine.

Maybe you can save the configuration of your AC66U to your computer and reload it on your new AX88U?

Who setup the old router? Seems like this person knew what she did (so ask him/her for help again) or was it just plain luck that it worked? Maybe you know someone how knows more about configuring a router that you can bring in? You can also ask a professional or ASUS support for help (you payed for your new router, so you have a right to use their help and support resources).

Whatever you choose, make sure the setup meets Roon Labs published networking best practices:


I double checked those Network Best Practices and found that Multicast Routing was disabled. Huh, everything worked again for some time.

Cause I bought a new router and I had an older one I updated my network with two AiMesh nodes. It was easy and everything worked except Roon Core AGAIN. It seems that AiMesh and Roon Core don’t like each other. So I removed nodes and reseted everything and insalled AX88U router alone again. But now Roon Core seems to be missing forever. My previous settings for AX88U router that have worked, worked no more. This time IGMP and Multicast Routing were enebled but no core.

After few days of networking all seems to be right but no core. With AiMesh something happened to AX88U even with same configuration.
Lucky me, my Roon yearly pay is after one month. So I lose only 1/12. And in the future I have to go on without Roon. Shame, but too much problems with Core during my Roon year. I give up.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.