Can't connect to Roon Core after upgrade to Build 216 on Linux [solved]

My setup: Roon Core on Lunux Ubuntu 16.04 LTE, latest updates installed, kernel 4.4.0-75
Everything worked, until I got a suggestion to “update roon”. After the update, roon clients (both on Windows 10 and android) can not connect to the core. It keeps reporting “lost connection”. If I decide connect to another core, it properly identifies existing core on my Linux server, but can’t connect.
Linux server is a VM on ESXi Hypervisor 6.0 (latest updates and VMWare tools installed), 2GB Ram, 2 cores, and it is dedicated to Roon (no other applications use it). All connections between PC are wired (Gigabit Ethernet via Cisco switch) except for Androis and iOS control points (on WiFi – mesh of Cisco enterprise access points, all up to date and managed properly). No network issues whatsoever. All of them are on the same IP4 subnet (, computers can ping each other with sub-ms delays and zero lost packages.
MAIN processes on the linux server run at “over 100%” load all the time.

Could the server upgrade go wrong? Should I re-install Roon software, or what?

OK, I just manually reinstalled the Roon server (it appeared that the newest build is 218), and now everything works fine. Looks like the auto-upgrade feature for linux doesn’t work properly. Anyway, I’m a happy camper again. Will be Rooning again tonite :wink:

I am glad you are back in business! :smiley:

Just wanted to reply to your comment. It does work just fine. I have gone over two builds with auto upgrade no issues. :wink: