Can't connect to Roon Core anymore and roon server stuck in a loop

(AT) #1

Core Machine (Operating system/System info/Roon build number)

Win 10 Pro 1809/core i7 2600K/SSD 256/RAM 16GB/Roon Server 1.6 Build 416 64bit + Music file on external USB Box ( Icybox) with 4 HDD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Vodafone Power station / switch 5 port Dlink

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Allo USBridge with roonbridge > USB > Denafrips Pontus

Description Of Issue

I run Core (RoonServer 64 bit) and Roon Remote 32 bit on the same PC as support suggested me to fix some performance issues. Suddenly I can’t connect to core form the PC and also from other devices (Phone, Tablet). Roon server correctly start but when i run remote from the same PC it stucks on loading icon. I see roonserver reading disk content from the led of USB box. After some minutes roon remote interface appears but without any album cover. In the upper right side I can see the circle that means library reading and search icon but that’s all. The interface doesn’t responds and after a few seconds it goes to “waiting for remote core”. That it goes back to loading and repeats every step described above. Sometimes when roon remote screen appears I can see all albums but it disconnects again and the loop restarts.
I reinstalled roon server but nothing changed.
I tried with Jriver and I can play files from any of the exernal disks

Please Help me!!

(Dylan Caudill) #2

Hi @Andrea_Tacchetti,

Were there any changes to your setup around the time this started occurring? Any newly imported media or any Windows updates?

(AT) #4

I updated BIOS one week ago but after update Roon worked well until today. I saw windows update cronology and the last update indicated is on july 14. I didn’t add or remove any hardware or update drivers (at least voluntarily)

(AT) #5

Any Idea? Help!!:sob:

(Dylan Caudill) #6

Hi @Andrea_Tacchetti,

Just to confirm, have you tried rebooting your Core machine since this started occurring?

If that yields no change, I was hoping you could reproduce this issue once more and make a note of the time that you see the remotes disconnect. After that we will enable diagnostics on your account so we can take a closer look.

(AT) #7

Thank you Dylan, I reboot several times but without any changes. I’ll reboot once again and I’l write you the time of the disconnections in a few minutes.

(AT) #8

I logged in at 16.36 (italy time) at 16.39 (near 40) roon screen appeared showing error "loading saved page and after a few seconds (16.40) the disconnection screen appeared and aftera few seconds went back to loading page restarting the loop. Ar 16.42.22 it connected again with “error loading saved page” text and disconnected a second after. Loop restarted connecting at 16.44.27 and disconnecting at 16.44.39. Now server and remote are running so that you can see and monitor the loop.
Thank you and bye
Andrea

(Dylan Caudill) #9

Thanks, @Andrea_Tacchetti. Diagnostics have been enabled.

Meanwhile, I was hoping you could try something for me — You mentioned you’re running RoonServer and Roon on the same machine. If you temporarily switch from using RoonServer to the all-in-one install of Roon (“This PC” when selecting a Core) is there any change?

(AT) #10

Hi Dylan, I tried to do what you asked but when I opened roon with my surprise I find it connected (the phone still can’t connect) but without thumnails. I can scroll but if I try to click on something roon freezes for a while than wakes up an so on. In the meanwhile thumbnails are slowly appearing on screen as you can see in attachments

It’s like if Roon is regenerating or searching for all albums (at this very moment it’s trey Anastasio album)

Thanks

Andrea

(AT) #11

An update. Given the fact that roon was connecting to the core again (even of with the periodic freeze) I tried to restore most recent backup but around 28% it failed. I don’t know if the problem is system disk space (15,6 GB). After failed restore the situatione came back to previous situation with freezes and thumnail rebuilding.

(AT) #12

I finally did what you asked. When i switched to “this PC” i had to login and create an empty library (scan to my library would have taken too much). However with this configuration Roon was fluid and without any freezes. Whan I went back to localhost library behaviour was the same as before with the same issues.

(Dylan Caudill) #13

Thanks for the updates, @Andrea_Tacchetti.

I can confirm that the diagnostics report has reached our servers and I’ve updated your ticket in our internal system to reflect the latest info you’ve passed along. I’ll be sure to follow up as soon as I’ve received further feedback from the technical team.

(Dylan Caudill) #14

Hi @Andrea_Tacchetti,

I spoke with the team about their investigation and wanted to follow up with you.

You mentioned previously that there was not a lot of space left on the drive where Roon is installed. Are you able to free up some space here? Is there any change when doing so?

(AT) #15

Hi @dylan , I’ve a 250GB SSD with 15,6 GB of free space. Free space is more or less the same from several months (I’m planning to migrate to 500GB) so I don’t think that it should be the problem. Anyway I freed up to 68,5 GB but there isn’t any change. After boot this morning behaviour was the same as yesterday after booting (loading>connecting>no core loop).

Thanks

(Dylan Caudill) #16

Hi @Andrea_Tacchetti,

Just to confirm, all of your media is stored via USB? If you disconnect this USB device and start up Roon, are you able to navigate the app without the crash occurring?

(AT) #17

I disconnected all the local storage and restarted roon server. Now Roon connects and doesn’t lose connection but I have the same issues (no cover > periodic freezes).I see my tidal library but as with local files cover begin to appear see first image but if I close Roon control and restart it they disappear again and newly and slow begin to appear (see second Image)


I add one thing: after doing test without local storage I turned on usb external box and when Roon found the connected storage (I saw led on the box blinking) roon control freezed and disconnected and went back in the loop

(Dylan Caudill) #18

Hi @Andrea_Tacchetti,

Thanks for performing this test. I think that we there are two separate issues occurring here — First, let’s focus on the crashing when the USB media is connected. Once that’s resolved we can further investigate the slowness you’re seeing.

Regarding the crashing — I’d like to try the following next which should give us more information about what is occurring.

  1. Disconnect the USB drive and connect to Roon
  2. Navigate to Settings > Library and set both Background and On Demand Analysis speeds to Off
  3. Reconnect the drive
  4. If the crash occurs again, make a note of the time you see this and respond here with that time. If it doesn’t occur, let us know how things go after playing some music and using Roon like normal.

Thanks!

(AT) #19

To be more clear I nver had a crash but just a disconnection or the switch from the normal screen to the loading screen when connecting USB drive. I did what you said and I notices Roon adding local files at 19.58.27 while at 19.58.55 came the loading page and the loop restarted.

Thank you

(Dylan Caudill) #20

Thanks for giving that a go, @Andrea_Tacchetti. I’ve enabled diagnostics and will pass the report along to the team once it comes in. I’ll be sure to keep you updated as soon as I have further feedback.

1 Like
(AT) #21

Some news for @dylan . I unistalled and reinstalled roon server (64 bit) and then I restored my last backup. Restoring was succesful. When I launched Roon control, it connected (but Phone and tablet didn’t) once again covers were missing and trying to browse library caused freezing, Covers began appearing but after restarting roon control were all missing again. Even if i browsed an album page it freezed until cover appeared. I tried to play something and it worked. When i clicked on now playing screeen it freezed again waiting for the cover (the same that I saw in album page) to appear. Playing bar also freezed while song kept playing. After some time and clicks in the user interface playing suddenly stopped and at the same time Roon control disconnected. Anyway Roon server was always up (see attachment) and never crashed. After that. behaviour was the same before unistall/reintall and restore.

So now I can say that even after restoring my Roon is unusable… Just to add one more thing every other audio and non audio application works well…
5