Can't connect to Roon Core from Roon Remote

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

I am having issues connecting to my Roon Core from my Android Roon Remote.

I can’t seem to get passed the “Waiting for remote connection” page when I have the phone connected on the same subnet. I can however see, with tcpdump, that the two devices are communication using all sorts of ports. So they are for sure seeing each other but nothing happens.

Trying to connect my phone to a different subnet is actually better. Now I get passed the “Waiting for remote connection” page. I can browse my music, I can see my audio devices but I can’t start any music but I can change volume on the audio devices.

I actually tried to install Roon Remote on my PC as well even though it sits on a different subnet. Same result as with the phone connected to a different subnet. I can see and browse my music and change volume on the audio devices but I can’t start any music.

I find it very weird that it works better for my phone on a different network. I also find it a bit weird that I can’t start any music since the audio devices are connected to the same subnet as the core. They should see each other just fine.

Also worth noting, everything was working just fine a couple of months ago. I haven’t had the time to enjoy music lately.


Not sure this can be the case since Roon doesn’t work over separate subnets.

Nonetheless, to get appropriate support, please change the thread topic to #support, and complete the template from this post. Please provide as much detail as possible.

1 Like

Moved to support.
Your network equipment may have had a routine change that has affected the broadcasts so please give details on all such equipment.


Hey @Peter_Osterberg,

First off, welcome to the community! We’re excited to have you here, and I apologize that it’s an issue that has prompted your first post.

Both @Martin_Webster and @ged_hickman1 are steering you in the right direction here by providing more detail into your full setup (as well as making sure Roon is functioning all on the same subnet.) This information is crucial for the support team to better get a sense of what might be going on :pray:

I’ve copied and pasted the information we’ll need to your original post. If you can fill that in, that would be extremely helpful!

I’ll be monitoring this thread for your reply.

All devices are normally connected to the same subnet.

As said before I can see my Android phone communication with the core when they are on the same subnet. There are UDP packets going between the devices both bi-directionally.
Android phone, having this IP doesn’t get me passed the connection screen.
Moving phone to subnet let’s me get passed the connection screen and browse my library but I can’t start any music.

All other devices on the same network are working just fine, +10 devices ranging from phones, TV:s, media players, projector, etc all working just fine. I don’t see any routing issues there.


Why do you even have two networks?
The most common use case is for isolating devices by shifting them to different networks (security reasons). The expectation is that your phone on can’t see, let alone connect to, your Roon Core in That is why others see routing issues by just reading your issue description. That you can’t play music is typical for misconfigured network setups because it might be possible to route unicast traffic (control Roon) between networks but the also needed multicast traffic (detect Core and Endpoints, play music) is usually limited to it’s own network.
Why exactly your phone can connect from the other network but not the one the Core is in, I don’t know, but chances are high that some needed packets are just traveling to the wrong network.

PS: I can see managed switches and WiFi stuff listed in your network description, but where is your Router, modem, etc. that connects you to the internet?

I am sorry for leaving that out…

I want connections to work, which is the supported way to do it, when my phone is connected to

I moved it just to test when it didn’t connect as it should on my multimedia network.

As you probably know there no need for routing when two devices exist on the same subnet. So there should be no reason for me to include that information.

And yes I have 16 different subnets in my home for security reasons and I am quite qualified when it comes to routing. My firewall/router is a linux box with iptables manually configured with neovim in a tmux session using zsh shell. I use netfilter-persistent to restore rules at boot an everything is backed up using rsync to a different subnet which is only used for backups.

But what’s really important is that roon can connect to my devices when they all reside on the same subnet without any routing necessary since Roon doesn’t support that.

I think I mentioned that I can see the two hosts actually communicating using tcpdump… :wink:

I also use VLANs for security reasons. My count is 5 - which is already more than I would expect or recommend for a typical private household. 16 sounds unreasonable to me (just my opinion, hold it as you like).

How do you think security works when you allow free routing between your different networks – which is what seems to happen from your description? When no routing is needed, why do you allow it then? If it’s not allowed, how do you explain the behavior of your phone when connected to the other network?

Roon generally doesn’t work without internet access (license checking, metadata access, …). So routing is usually required for a working Roon installation.

It’s still unclear what operating system you use. Given your networking issues, if it is not ROCK, part of your issues might be related/resolvable by the firewall and/or networking configuration on that machine.

AFAIK exists currently a known connection issue with Roon Server on MacOS but it is probably unlikely that you run MacOS on your NUC. So did it ever work and stopped working? Are other clients (PCs, tablets, other phones) on the same network able to connect? Are other devices also able to see and connect to your Roon Core from other networks (VLANs)? Are there any VPNs in play on your network?

This does not prevent important/expected packages to take another, unexpected route eventually or important/expected additional connections being blocked or routed through the wrong network for some reason.

Just to be sure, that is the goal you try to achieve – and not how it works right now for you?

Don’t know what this should tell anyone. You might be better off using a well respected firewall distribution of some sorts (for example: pfSense, OPNsense, IPFire). Again just my opinion, hold it as you like.

My Roon Core is running on Ubuntu server 20.04LTS. It had been doing that for two years without hickups. I was surprised that my Roon app didnt just connect as it usually did.

Mentioning other subnets was clearly a mistake, it seems to have confused a lot. I mentioned it because it oddly worked better (I didnt expect any connection at all since this isn’t supported), and I only tried it because I was curious since correct network didnt work.

I havent had time to reverse Roons networking habits but I assume that the usual suspects mDNS and broadcasting are in the mix for clients to discover the server. (Once again they do find eachother, they are exchanging packets but clearly not enough to get passed the connection screen in the app). is my multimedia subnet and is considered to be a low security network. Most of my other networks can freely route TO this network. Packets belonging to sessions initiated from higher security networks are allowed to travel back.

Will report back more later this week, will working too much to play with this the next couple of days.

Thanks for trying to help out!

If this is the “Choose your Roon Core” screen, then read below:


It is not uncommon that you can connect from a different network (if routing is allowed) but expected that playback doesn’t work. You’re not the first one who tried this. :wink:
As working playback is part of the Roon solution, this is one of the reasons why multiple-network-setups are not supported.

1 Like

Hey @Peter_Osterberg,

Thank you for the additional details on your situation and setup. Because you are running a more complex system with 16 subnets, a Linux Core on a VM, and a hefty network firewall setup, this surpasses the threshold for Roon support.

I will move this thread to our Tinkering category where many of our knowledgeable members from the community may be able to provide additional assistance.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.