Can't connect to Roon core since I got a new router

Core Machine (Operating system/System info/Roon build number)

Win 10/AMD Ryzen 3 MSI B450 MG, 8GB RAM

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS AC3100 RT-AC3100 router connected to core machine by LAN. Macbook Air running Roon is the control/output device connected by wifi to router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonore Microrendu connected to an ASUS RT-n66 router by LAN. The RT-n66 is set as an access point. The RT-n66 is connected to the RT-AC3100 by wifi

Description Of Issue

When I try to connect the Macbook Air control device to the core machine, Roon gives me the message “connecting failed” and roon keeps attempting to make connection to core and keeps failing.

I replaced my router and created a new network and then was unable to get my conrol devices to finfd my core.

In the past, I had Roon server on my core machine and was able to conrol roon from an ipad using roon remote or from a Macbook air running Roon. Now I cant connect to Roon core. I am not currently using Roon Server.

Hi @Peter_Samuels,

In the router settings can you confirm that Enable Multicast Routing is enabled?

ok, I’m gpoing to try and find that, thsanks

Can you tell me where to find that setting in the router interface?

ok. found it under LAN>IPTV

Roon can now detect the core machine but repeatedly tries to connect and fails. I t has been trying to connect for about 1 minute

there is an option on the router to “Enable efficient multicast forwarding (IGMP Snooping)” Should I enable this?

Thanks for helping, Dylan

Are you still with me, Dylan?

Hi @Peter_Samuels,

Just to clarify here, is it just the Macbook air that is having issues connecting to the Roon Core or is it both Macbook air + iOS devices?

Yes, you can give that a try, we have seen that setting help with connection issues in the past.

I would also double check to make sure that Roon is listed as an exception on your Windows and OSX firewall. You can use these instructions for the Windows firewall and these instructions for the OSX firewall.

I should also note that we (support staff) are often helping multiple clients at one time, and I kindly ask for bit of patience between messages while your response reaches our queue again (as it may not be instantaneous).

– Noris

Thanks for explainning that you are multitasking!

Neither mackbook air nor ipad will connect to core

I will try to alter the firewall as you suggest


After allowing roon apps through windows firewall, both macbook and ipad can connectto core on windows PC

Noris and Dylan,

The issue must have been firewall.

Thanks for your help. I’ve got control via core PC, Macbook and ipad. I can play music through ipad, macbook and Sonore microrendu.

I am ok for now.

Thanks again


Hi @Peter_Samuels,

Glad to hear that after making those firewall changes that the issue is resolved!
Hope you have a great day and an enjoyable Roon experience!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.